Layout Glitching between SU

(Using most recent Pro Versions on a new Mac working on the most up today operating systems)

Since yesterday, a model Ive been working on in layout has started to glitch, I have scenes that are all saved, yet in the import to Layout there are hidden elements appearing in them, which are not showing in the scene in Sketchup (I have updated the Layout file in document settings). Ive tried resetting the camera and all sorts but it’s still not resolving.

On top of this Im missing lines in the import? (EG A rectangle is missing one side, unless I double click in the box to show the SU view and it shows up). This has all happened since I last used Layout last week. Ive never had issues with it like this before and I cant seem to work out the solve.

Any thoughts?


Much easier to work out what the issue could be if you could share the Layout model…

I was waiting for that reply, Can you tell me how I attach to here? (1st time poster on this or indeed any forum ever…!)

Depending on how large the file is – either drag and drop it into a reply or share a link to Dropbox or some other sharable online storage service.

:slight_smile: m hoping this has worked…:slight_smile:

Something Rotten Plans 2~.layout (10.9 MB)

What scenes are having these issues ?

Can you share some screenshots of what you are experiencing ?

loads of the lines are either missing or half finished

Bizarrely Layout just crashed and when I rebooted the scenes with the hidden images that were showing seem to have resolved.

Although I have just noted that the model in SU is doing th same thing with these views, but the lines appear solid when I shift the camera. (View below from the SU Model)

Does the rendering improve if you change the viewports to vector or hybrid ?

Depending on how complex your model is and your workflow – you might suffer a performance hit in Layout with vector and hybrid…

1 Like

Rendering the viewports in Vector will help with most of it.

I don’t see what you show in your screenshot from SketchUp, though. This is what I see in SketchUp.

You might see if turning Profiles on and setting them to 1 helps.

Your scene called “Stairs Front ELevation” might show some graphic weirdness because you have two copies of the stairs group stacked one in front of the other.

I notice in LayOut you’ve modified the Camera properties for some of the viewports. You shouldn’t need to do that for any of them. The viewport in the upper left corner of the sheet is using the “STairs OpenBase” scene but you have a scene that could be used directly without modifying the camera.

Are you still using SketchUp 2021 and Mac OSX 10.5?

Looking at your SketchUp model I notice a few things you could improve that would make your workflow easier and more efficient. If you are interested in that stuff I can share it but maybe you are happy the way it is.

I have to ask, is there a reason you’ve chosen to exclude all of the scenes in your model from animation? The parentheses around the scene names indicatess that. In this case, since all of the scenes are excluded, there’s not much point in doing that. It just makes every scene name and tab longer.

Hey DaveR,

That you for this, I am self taught in 2020 and so a lot of this is fairly above my knowledge so please, if you have any tips as to improve that would be most appreciated.

To answer,

I am using the most up to date SU, and the most up to date Mac operating system (my Mac is literally a month old)

I turn off animation in scenes so that when you are checking each scene you dont have to wait for it to travel, it just snaps to it.

I have modified some of the angles in Layout, tbh, this model has been really tricky (its the most complex thing Ive ever had to model) and so when something isn’t correct, Ive just tried to make it work as best I can in order to meet deadlines.

Thank you for the Vector tip, that rectified it completely!


Please update your forum profile. When that information is accurate it helps us help you.

Unticking the box for Include in animation has no effect on scene transitions in the model. That only omits scenes if you are exporting an animation video from SketchUp. Turning off scene transitions in Model Info eliminates the delay between scenes.
Screenshot - 8_24_2023 , 10_26_27 AM

A better process would be to modify the camera position for the scene in SketchUp and leave the viewports alone in LayOut.

I’m about to get started with an online student but when we’re finished I’ll come back with some additional stuff.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.