Layout crashes every time I adjust my viewport

When I’m sending my view to Layout, I immediately adjust my viewport size and position, and Layout crashes every single time.

I’m no wiz with computers and no pro with Layout, although I do have a lot of experience with sketchup, I’ve only used Layout a dozen times for presentations and this has never been an issue in the past. I tried several ways to clean up my computer and optimize my sketchup model, nothing has helped at all. My laptop is a few months and very strong, so the issue has to be with Layout or Sketchup, I can’t figure it out.

All the research I’ve done doesn’t seem to help, everyone has the same opinion about Layout, that it usually works really well.

Please help me try to figure this out, I feel like it’s something so simple that I just haven’t noticed myself…

How about starting your LayOut file. Don’t make any adjustments to it, just get it started and then save it and share it so we can see what you are working with.

Did you install SketchUp and LayOut correctly using Run as administrator?

Is your SketchUp model file saved to an internal drive on your computer?

Ok thanks, I’ll try and get a few things done and send.

I doubled checked the install already and ran a Checkup. everything checks out.

I had it saved to an external harddrive first, then transfered to my desktop, same issue.

Here’s the drawing just with a few dimensions. I saved it then tried to adjust the viewport and it crashed.
KITCHEN - PENINSULA 2.layout (5.6 MB)

I didn’t have any issues with your file crashing for me but I did have a look at the SketchUp model. I fixed incorrect tag usage and purged unused stuff. This is my usual cleanup process.
Screenshot - 6_4_2024 , 6_17_22 PM
Screenshot - 6_4_2024 , 6_17_48 PM
Here’s the LayOut file after cleaning up the model. Note the file size reduction after the cleanup.
KITCHEN - PENINSULA 2 dr.layout (3.1 MB)

It’s possible that something which was purged was causing the crash. It also might be that there’s something else. Were you getting BugSplats and were you sending them in?

I set a common scale for the viewport and dragged the edges a bit to resize it. No problems with crashing. You should set the scale before starting to add dimensions. See if you can move the viewport or drag the edges of it in this file without getting any crashes.

Best practice is to don’t do that. Always save the file while you are working on it to the internal drive. Copy it to an external drive if you must or use your Trimble Connect storage if you need to make the file portable. As for your LayOut projects the thing that I find works best is to create a project folder which contains the SkeetchUp model(s) and any other references as well as the LayOut file. Keep everything for the project in a common folder. This makes the reference links easy and you’re not likely to damage any of those links.

If you want the purged version of the SketchUp file out of this LayOut file, right click on the viewport and choose open with SketchUp. If you want to replace your original SketchUp model with this one, use Save as … and save over the original.

Ok what you did seemed to have worked.

I originally copied the model from a master SketchUp file to try and shrink the size of the file, that might explain some of the incorrect tags. However, can you send a link or something with steps for your cleanup process, because I thought I purged. I’d like to try this with my master file, there must be something wrong with my original model.

It might explain it or it could be something else.

Sorry. I don’t know of a link to give you for that. I used an extension from Sketchucation called Default Tag Geometry to fix the incorrect tagging. Then I used another extension from there called Purge All to purge the unused stuff from the model. You can do that via Model Info>Statistics>Purge Unused. I use the extension because it gives the report I showed.

Generally the best process is to maintain correct tag usage and clean the model up frequently so stuff doesn’t build up.

I wasn’t able to see exactly what it was that caused the crashes for you. I never got a crash with your LO file. I can only guess that it was something in the SketchUp file that didn’t really need to be there anyway.

Good luck going forward.

Hi Dave,

I apologize for not taking the time sooner to thank you for all you did to help me.

The model you edited for me really helped speed up the work to finish my model as it was less heavy and easier to navigate through the model. Now that my model is complete, I’m ready again to start using Layout - I avoided Layout for my previous work because I was in a time crunch and had to get the work done. I was hoping to jump right into Layout this time around and it work seemless as usual…Unfortunately, I wish did not come true. I am having the same issue and it just keeps crashing.

I have to get this project done asap and I DON’T KNOW WHAT TO DO lol…

Is it possible for you and I to connect to go through the issue and troubleshooting. I’d even be happy to pay you for a couple hours of your time.

Thanks again.

Id be happy to help you with it. Not tonight though. Power is out here. Waiting for it to get fixed.

Send me a pm with your email address so we can connect when it is fixed. Also send me whatever you have for a SketchUp file so I can see where you are at.

Thanks, I’m not keen on getting much more done tonight so no worries there.

Edit you post to remove your link and email address. Click on my name at the top of this post and then Message and send them in a pm. Right now your email address and file are public for the whole world to see.

I had a look at your SKetchUp file. It needs a bit of cleanup.

Fix tag usage:
Screenshot - 6_19_2024 , 4_42_18 PM
Purge unused stuff:
Screenshot - 6_19_2024 , 4_42_38 PM
And resize the huge texture files. There’s no benefit to having those giant textures but they bloat the file making it sluggish. It would also bog down LayOut.

AJ-Cindy-Langley-Ground Floor purged.skp (10.0 MB)

Next thing to do is make sure you have all the required scenes set up to show the model the way you need in LayOut. I think you should mostly be ready to go from there.

I apprciate you cleaning up the file former and listing the things I need.

I’ve worked on much larger files before without any issues so I’m still a little bit lost as to what’s causing this to happen. Although, I’ll make more of a habbit of following these steps. Can you just confirm a few things for me?

  1. Should I set a tag for every single object/group that I create?
  2. The purge you did, is it through the extension you mentioned previously?
  3. I already have my the scenes I need made, is there anything else I’m missing with my scenes? I had a hard time figuring out how lock to “Active Cuts” in my scenes so I always have to adjust them. Do you know how to do that?

One last thing; I don’t know if you noticed, but when I create a new Section Cut when everything is deselected, the Section Cut is miles long. Any idea why that might be?

You probably don’t need a different tag for every object but it’s generally a good idea to give tags to all of the groups and components in the model. Make sure you are keeping all edges and faces untagged, though. Also don’t leave any ungrouped geometry.

Yes. You can purge unused through Window>Model Info>Statitistics>Purge Unused. I just use the extension because it gives that nice report showing how much has been purged.

I didn’t look that closely at your scenes but you do want to ensure that camera, tag visibility, section cuts, and styles are set up correctly.

My guess is you aren’t managing styles correctly and probably not updating scene properties right. The active section cut should be getting saved as a scene property. Do you sometimes see a style warning message when you create or update scenes? If so, what option do you choose? Or did you disable that warning?

Section planes extend to encompass everything in the context. If the section plane is miles long, it indicates you have some bit of model at a huge distance from the rest of it. That huge section plane should then be considered a red flag and you should go hunting for whatever you’ve stuck out on the other side of the county.

Trust me I went on that hunt a few different ways. I tried to delete everything for miles around my model and copied my model group (walls and floor only) into a new sketchup file, problem is still there.

I don’t ever get warnings. Now that i think of it, I think my scene issue is related to the section planes being huge becuase I have deleted and recreated new scenes. Here’s an image of the Scene Update dialog to show you what I’m saving.

Make sure all tags are turned on as well as Hidden Geometry and Hidden Objects. There’s something out there if the section plane is huge.

Go into Preferences>General and reset warnings. Section cut, plane, and fill states are style properties. If you change section settings before creating or updating a scene, you will need to either update the style or create a new one. Or possibly select a different existing style so you aren’t loading up the model with identical styles. If you don’t do update or create a new style and just create a scene, you should get the warning asking what you want to do about the style. If you disabled the warning you could create problems for yourself.

I have a lot to learn here…do you have a suggestion on what tool to use to resize, and what size is acceptable?

I used an extension from the Extension Warehouse called Material Resizer. As for acceptable sizes it really depends on the use. For some small incendental thing the texture can be very small. If you are just modeling for straight export from SketchUp or LayOut, probably nothing larger than 1024 pixels will work plenty well. You should also look at things that have textures which could be replaced by simple colors. A common thing I see is books from the 3D Warehouse with a texture for the covers and even the edges of the pages. Unless you are creating close up views of the books, the covers probably don’t ned to be textures and certainly not the page edges. Look for stuff like that and delete those textures.

unfortunately that extension is not compatible with the latest version of Sketchup…

It mighht not show that it is compatible with SketchUp 2024 but it works fine. What version of SketchUp do you think I was using when I ran it for the screenshot from a week ago?