Why won't LayOut recognise parts of my model? Help!

I am using Layout to make scenes of different layers in my model in plan, which I will take to Photoshop. Its for my final project for my garden design degree which is due on Monday so panicking slightly…!

I am changing textures etc in my SketchUp doc and then going to a layout doc, pressing update and then exporting. Layout is refusing to show up one particular layer, which is the trees. The file is linked because when I change textures, that works. It just refuses to see the trees when I turn them on. It was working fine earlier today, I have an old version where the trees are showing up. The trees are just circles with a texture filled in. Nothing elaborate. They are on their own layers in SketchUp so I can turn them on and off.

This is the first time I am using Layout to produce images for photoshop. I was told that the resolution is much higher than just simply exporting straight from sketchup and I need to print at A0.

Is this a bug? Is there anything I can do?

Really, really appreciate some help.

Many thanks

Are you updating the scene in SketchUp after changing the textures? If you change visibility states for layers, i.e. turn a layer “On”, you have to update the scene in order for it to “take”. You can check that by clicking on the scene tab after making changes. If your changes go away, the scene hadn’t been updated.

Do the viewports show their associated scenes as Modified in the LayOut’s SketchUp Model panel?

Ok, I think its working now. So first off, when was updating the scene (right click tab update), it wasn’t doing anything. when i clicked back in tab it went back to before.

then i managed to get scene updated, when to LO, still didn’t update (doc status CURRENT).

Then i sent back to SU and saved file. then LO updated (doc status was still CURRENT, what does this mean?)

I really hope this continues to work.

You are a life saver Dave, thank you

1 Like

I’m not sure what happened that the scene didn’t update the first time you tried.

There’s also the circular arrows button in the Scenes panel for updating the scene. By the way, look at the Scenes panel. There a list of Properties to save which shows you the kinds of things that get memorized with the scene. Also note that if any are unticked when a scene is created, those properties don’t get saved with the scene. There’s a similar thing for updating scenes if you do it from the Scenes panel. This can be very powerful but it can also create problems if you don’t know how to use it correctly.

As for updating the reference, you do first need to save the changes to the LayOut file. With larger files like yours it could take a moment for LO to recognize the reference no longer matches the embedded version. That’s really what happens when LO tells you the reference is out of date. If you were to close the original reference file and then open it from LayOut, the updating will be done automatically when you go back to LayOut after saving the changes in SketchUp. You can right click on the viewport and choose Open with SketchUp.

That updating thing also works for inserted text (RTF, TXT), spreadsheets, and images.

Yeah I am using stuff I don’t really understand - dangerous…

I can’t see that list of stuff in scenes panel.

Anyway, I better get on with this

Thanks again Dave

Click on the button second from the right with the black downward pointing arrow and the white + on black. The button will invert and you should see the list. I don’t have thumbnails displayed for scenes. For me they just slow things down.

Good luck finishing it up.

Got you - tiny button!
Thank you

I just managed to export all my scenes without any problems :slight_smile:

1 Like

It sounds like you didn’t save the SketchUp file after updating the scene. Then you went back and saved the file, and then LayOut updated to the new scene configuration. You have to save the SketchUp file first, each time you want LayOut to update to changes.

Good luck on the project and degree!

1 Like

In sketchup if you do a 2D image export you can set the output resolution to the equivalent of AO
depending on the resolution you need up to 9999 pixels ( so perhaps @ 200dpi), but I think the Layout options are better for control of line weight etc. An image such as yours might benefit from hybrid mode to make use of the textures as well as sharp line work?

1 Like

Yes thats exactly what happened - I have never used LO to export scenes before. It certainly worked in terms of image resolution. My photoshop file was so huge it refused to save (20 acres at A0). So that was another stress but I rasterised the layers and it reduced the file. Yesterday was a stress!! thanks for your help.

I did a google search and came up with 300 dpi, but the photoshop file was so huge it refused to save until I rasterised all the layers. I think its ok now. I will do 200 dpi in future.

Layout seems to give thinner lines than a normal export. I really dont know what I am doing! google and you guys are teaching me :slight_smile:

in Layout, the tool palette - sketchup model / styles there is a line weight option, you can increase it to thicken those lines, which would perhaps look thin at the AO size?

300dpi at AO is a biggish file, but you may not need that resolution for your print. If you could test print a few pieces at different resolutions to determine what you need. Always good to work back from what you eventually need, so you’re not bogged down with large sluggish files that you dont need, but bigger can always be made smaller but smaller does not always scale up so well.

I don’t know how you are exporting, but using a lower export quality setting often doesn’t matter for most purposes (LayOut File menu/ Document Setup Window/ Paper. I don’t know why LO pdf files are so large when other programs produce fine quality with a fraction of the mb. But I run across this all the time. A hassle if you use LO in construction files. You can’t just email them to people the old way. Glad its working out-one way or another!