Missing axes on startup


#1

All I just downloaded sketchup. When I open the program I see no Axes thus there is no functionality. I have uninstalled it and reinstalled a second time. The first time I did not install as an admin, thus i have completed the 2nd install and I still see no axes.

I have a 2016 surface pro 4 running windows 10 pro with a Intel HD Graphics 520 display adapter supporting all three monitors.

I have checked to make sure that the axes are turned on in the view tab. and I have checked scale?

At a loss as I am completely unfamiliar with this product.


#2

Go to Window>Preferences>OpenGL. Untick Use Fast Feedback. Any improvement?


#3

Your graphics card is on the list of ones to avoid in the pinned topic…

Graphics cards to avoid:
https://www.techpowerup.com/gpu-specs/?memtype=System%20Shared&memsize=System%20Shared&sort=name

I have no idea if this could be the cause.


#4

Thank you both. looks like I will uninstall and see if there is another option.


#5

Uninstall what? Did you try my suggestion?


#6

DaveR
I had the same problem and used your solution. It worked! THANK YOU.

If it’s helpful for others, I can add extra details. I use the current version of SketchUp Pro, and have been using it a lot lately. Today I opened SU, but no axes appeared. I could open a sketchup file, and scene tabs would appear with names, but still no image in the screen. I could even ‘send to layout’ and get an image to transfer, and appear, in layout. But nothing in the SketchUp screen.

Unticking the ‘Use Fast Feedback’ box brought things back to normal. I don’t know what this option does, or if my setting for it changed for some reason, but unticking it fixed my problem.


#7

Hi Warren,

I’m glad that worked for you. There have been quite a number of reports of the same sort of thing lately. Coincidentally the Surface Pro with Intel graphics adapters seem to be a common thread. The integrated Intel HD GPus are well known to be inadequate in their support for OpenGL upon which SketchUp relies. Microsoft seems to be good at pushing Intel graphics driver updates that break OpenGL and affect programs that rely on it working right.

For the time being it sounds like things are working which is good. Hopefully they stay that way. If you have some reason to replace your computer in the future, get one with an Nvidia geforce graphics card. Historically they’ve performed very well with SketchUp and they don’t seem to be susceptible to the issues linked to the Intel adapters.


#8

It’s really not important to know exactly what this option does, only that it is an OpenGL optimization technique that is supposed to make certain operations go faster. But some GPUs and their drivers provide broken implementations that cause bad behavior in SketchUp. Turning it off causes a potential slowdown but bypasses the problems with these devices and/or drivers.


#9

I hate to sound like an idiot but I am not finding the path to opengl.
I have googled everyway to find windows preferences and i have no hidden folders anywhere on the computer. I can not seem to find it. I am running windows 10 pro. if you have any suggestions i woudl greatly appreciate them.


#10

Open SketchUp. Click on the Window menu. Click on Preferences. Click on OpenGL. Untick the box for Use Fast Feedback. Click OK.
Screenshot%20-%2010_14_2018%20%2C%204_42_48%20PM

Screenshot%20-%2010_14_2018%20%2C%204_43_05%20PM


#11

Yep…I use a Surface Pro.

Thanks again for your expertise, and willingness to share it.


#12

OK so i am an idiot, i spent hours trying to find opengl in the preferences folder of a “windows” file. After following your instructions within the program it appears to have solved the issue. Thank you very much for your patience and diligence.