Minute misalignment creates big problems


New to sketchup and thought I understood drawing objects that followed the global axes stating with 0,0,0 as a reference but clearly don’t.

I’ve created side panels for a shelf and some of them I can create dados very easily but there are others that upon close inspection are slightly askew somehow. I create a rectangle on a face and when I push it in, the action leaves a sliver on the outside edges. I zoomed in and can see that the push is not receding into the surface parallel to the sides.

Can this be fixed or should I just start redrawing it?

Is it possible to select the item and “show” its axes with respect to the global axes?

Is it possible to “realign” the object so as to align it with the 0,0,0 axes?

Is it possible to look at the entire project’s axes in order to determine if it is aligned with the world?

If not:

Is doing something like this a common rookie error?

If so, how to avoid doing this again or what can I monitor as I draw things to make sure that I am drawing properly?

Might I be doing something wrong when I am creating the component?

I thought I was on the axis when the rectangle tool turned red or green or when it said something like…“on red axis”.


How about sharing your model so we can see what you’ve got?

Sure, (try not to judge me too harshly, this is my first project)

I just got home and tried drawing a rectangle in one of the end panels so you could see wht was going on BUT THEY ALL WORKED PROPERLY! So, unfortunately, I cannot show you the issue I was having.

I will upload anyway.

Repisa_1~.skp (66.7 KB)

Under the Styles > Edit in the default tray there’s a “color” option for lines, “by axis” will color them accordingly if they’re aligned with an axis, globally or locally if it’s in a component.

In your case it looks like the outer face was moved on the red axis so it’s out of alignment. (The board is a parallelogram prism on the blue axis when it should be rectangular)

To fix it you can select the face, select the move tool, select a vertex, press the right arrow key and reference the opposing vertex. You may have to zoom in to get the inference green rather than black.
If the short lines are co-axial they should show up as green with the color option enabled.

A Note of Caution: This has a somewhat loose tolerance and so cannot be trusted to show really small errors.

Thanks but I need more information. “The outer face was moved on the red axis”…which object are we talking about? Or are you talking about all the boards? I’m not really sure where to look for this. So I cannot know which face to try to move.

If this has a loose tolernce, what is a better way to do it?

A good starting point would be here:

The learning Center, interactive videos by the SketchUp Team.

This has always been funny to me - it seems like this would be a fairly black and white (red and green?) feature - it’s either aligned to the axis or not, right? :rofl:

I’m sure there’s a good reason for it, but it’s just kind of an odd thing to me

When I changed the styles to light up by axis, without changing anything,

that is in fact, green for me.

Sorry, I took that shot from the other side but from the same perspective, you can see mine shows as green.

At heart is the way that floating point numbers (e.g., as used to store 3D coordinate point values) have been represented in computers for decades. Here is another post in which I talked about this issue:


Use the “by Axis” setting as a heads up to show you edges that are off , which you intended or think may be “on” --it is just not absolute.

I guess floating point precision is good thing to keep in mind, I personally don’t use the feature.
I’m entirely unsure if it creates a difference between machines, but it looks like you solved the problem on your own along the way. This isn’t the same model originally linked.

Wait, I have not changed the model. I have only reflected the narrower end panel after I was able to create the dados properly. It is exactly the same model.

As I mentioned above, when I turned on the color by axis option in styles, all the edges appeared green without me having to adjust any of the faces.

So while the faces do seem to be aligned with the axes, it is not as a result of anything I have done. As soon as I turned it on, the edges turned green.

Try this link, are the edges still green on the end panel?
[changed to direct quote so no chance of tampering]