Materials brings sketchup to crash

I don’t know how this happens, I did not add any new materials do my files. Every time when I am switching material libraries, sketchup crashes completely. I tried to restart my computer, and am now unstinalling and reinstalling sketchup. Anyone else experienced this problem? Is there another way to fix this?
I thought it was my file, so I created a new file, but it still happens.

1 Like

Thank you for the 27 bugsplats that you have sent in. I looked at several of the 11 that you sent in today, and it looks like the crash happens when you are doing random things, and can be soon after starting SketchUp, or it might be quite a while later.

It looks like you updated to macOS 14.3 in the last couple of days, but that should be ok, that’s the version I’m using. There is a Sonoma related crash that happens within a few minutes of doing a save, but that crash should only rarely affect SketchUp 2023, unless there is some other file related problem happening.

If you have auto save turned on, and get a crash, does the Recovered file in the welcome screen show the changes you have made since the last save? If they do, you could do a test where you don’t save at all for a long time. If the crash stops happening, it may be related to the crash we known about. If it does crash, and you’ve done some useful work since opening the model, hopefully the Recovered file will get you back to where you were.

Please let me know if you gt a chance to try working without saving, and if that reduces the number of crashes. Of course, make sure to save if you’re done working for now, and as precaution you could close SketchUp and open it again when you get back to working on the model.

So, right after writing that long reply I was looking into a new crash I had seen, which I was blaming our internal version on. Turns out the same action crashes in any version of SketchUp. If I resize the Colors palette, SketchUp crashes.

So, go back to working as normal, including saving, but try not resizing the Colors palette.

Thank you so much for getting back to me on this, at this point I don’t know what else to do and am about to delete and reinstall SketchUp.

I don’t think the bug splash has something to do with saving a file. I was working on a file that got too large and too slow. I used one warehouse piece that made the file unusable. I spend time to recreate my model into a new file, to make sure this won’t happen again.

The bugsplash happened all of a sudden, and I can recreate it. The Screen recording Videos seem to be too large to upload. Version 1 is with the model I was working on. Version 2 is with a new empty file right after I opened Sketch Up. I did not resize the Color palette.

Version 1: - Google Drive

Version 2: - Google Drive

Please let me know what I should try. I am not able to change any color due to the constant crashes.

1 Like

Thanks, I get a crash that way as well. The place it is crashing in the same as when resizing the palette.

I created a bug report, and sent a message to developers asking someone to make suggestions. Something has changed in macOS, that is now crashing all versions of SketchUp when using the Colors palette.

Next time you make it crash, fill in some details in Apple’s own crash window. Hopefully they will be able to see what crashed on the macOS side of things.

Will do. How soon is something like this usually resolved? It is very frustrating to work with it, plus I can’t just uninstall the update.

I did what I described as well. I also filled in the Feedback Assistant, and sent that report to Apple.

I don’t know if and when Apple would fix the problem, if they can on their side of things. One of our developers is looking at the crash, to see if that gives us any suggestions for a work around. He couldn’t get the crash in Ventura, and so is updating to 14.3 so that he can see the crash every time.

Me too!

Sort of…

Materials working fine on OSX Sonoma 14.2.1 (23C71) on my laptop…

MacBook Pro (Retina, 15-inch, Early 2013)
2.2 GHz 6-Core Intel Core i7
16 GB 2400 MHz DDR4
Radeon Pro 555X 4 GB
Intel UHD Graphics 630 1536 MB

BUT not on my office computer also running OSX Sonoma 14.2.1 (23C71)

Mac Mini
3.2 GHz 6-Core Intel Core i7
32 GB 2667 MHZ DDR4
Intel UHD Graphics 630 1536 MB

This has been happening to me as well for last month or so. I’m on a Mac M2 Max Powerbook. It’s so frustrating.

Sketchup is basically unusable for me at this point - is the only thing to do roll back the operating system?

you can also apply your materials using the online tool. limit your desktop work to the 3d.

but yes, otherwise, it’s rollback.

M3 Max MBP and it started happening to me also.

1 Like

It happens to me too :frowning: M3 Max MBP

When resizing materials tools palette. Very annoying!

1 Like

from the SketchUp team

Hello !

It happens to me too ! Does the sketch team can do something to fix this bug as Apple answer the changes won’t comme from them ? It is very annoying

update mac os to 14.4

I know, it’s counter intuitive, we’ve just spent a month telling people they shouldn’t rush updating their OS, but in this case, if you’re experiencing the issue, it’s because you’re using 14.3
and in 14.4 they fixed it. However, it’s fixed only fir sketchup 23, not earlier versions.

On their side, Sketchup apparently fixed it as well in 2024, but it’s not released yet.

Passe sur mac os 14.4, ils ont réglé le problème. Par contre, ça ne le règle que sur sketchup 23.1 - la dernière version. Si tu utilises sketchup 22 comme ton profil l’indique, il va falloir aussi mettre à jour sketchup.

What @ateliernab said is correct. Is there a reason you are still using 2022? In terms of Sonoma, 2022 is the version that has the most problems, and aside from updating to 14.4 won’t fix the Colors palette crashes, it also won’t fix the other crashes that people get in 2022 and Sonoma.

Bonjour. La mise à jour avec OS 14.4 a été un succès. Merci beaucoup

1 Like

Unfortunate to be reading this on my Sonoma Mac mini M2 after 10 crashes trying to use the materials pallet… kind of renders Sketchup useless…

Unfortunate to read that you haven’t updated to 14.4 in which Apple fixed the problem they created. That would have headed off at least some of your 10 crashes.