Materials assigned to various groups within groups but some groups' materials does not show

Hi there y’all! I am very new to SKU and have enjoyed the learning curve thus far! So this is possibly a very noobish and beginner’s inquiry into materials and textures; however, I need to give it a shot!

So in essence, I have created a simple 2D SKU of a landscape (a backyard with a house), and I have gotten absolutely stuck on why one of my materials/textures that I have assigned to one of my entities simply will not show up or is visible.

I have tried and tried to compare the different entities that do show their materials/textures correctly, and I also have tried assigning the particular material to all aspects: the face, the group, the component, both sides of the faces, reversed the faces, and tinkered with the materials/texture settings of all the other groups to see if there was anything I might have overlooked.

At this point, I have assigned a “metal roofing” texture to the entity group which has been tagged with “Gazebo.” However, no matter what I do, this texture/material refuses to show up. Please note that this particular group is on “top” of another group, tagged with “Gazebo Patio”, and both of these groups are on “top” of the group, tagged with “Property Lines.” I use “on top” meaning I created each of these entities separately, one after another. Also note that the entity/group tagged as “House” had cut-out the property line area when I created the “House.” Every other group is as if they were “on top” of the property line area.

I thought that perhaps I had grouped all of these entities under “Property Lines,” and I tried re-grouping just the property outlines while I had the other groups moved outside of the property outlines.

Anyway, I am hoping that some uber SKU pro’s on here can assist me in figuring out what the heck is going on.

There is also the distinct possibility that it may have something to do with my graphics cards (NVIDIDA GeForce 9800 GTX+ with 512MB of RAM each.)

I look forward to getting to the bottom of this! My .skp has been uploaded.

Best,
Jp

JoyceCortez.skp (1.0 MB)

You are getting classic Z-fighting because you’ve created faces that share the same space. the smaller faces are not “on top” of the larger one. They are sharing the same location and your graphics card can’t figure out which one to show. If you orbit the camera you’ll see a sort of shimmering effect as your graphics card tries to resolve this. Of course you notched out the ground for the house so there’s no Z-fighting going on there.

The only way you can put one object on top of another in SketchUp is to separate them with a little distance.

FWIW you have a bit of incorrect tag usage.
Screenshot - 5_2_2021 , 4_00_11 AM

I fixed that and an incorrect dimension and purged unused stuff from your model

JoyceCortez.skp (809.5 KB)

1 Like

Dave,

Gaaaaaahhhh! The ONE thing I didn’t think of! So I’ll need to start making the groups 3-dimensional!

I appreciate your help!

How do I check the geometry of my .skp’s?

Thank you!
Jp

Well, SketchUp is a 3D modeling application. Or at least put some vertical separation between the flat objects.

I used Default Tag Geometry and Purge All from Sketchucation to clean up your file. One key thing is to make sure you are using tags correctly from the beginning. Do not give tags to edges and faces. Create them and leave them untagged. Only give tags to objects (groups and components). Also purge unused stuff from your model as you go. You can do that without a plugin via Model Info>Statistics. Keeping that stuff straight as you go saves you a ton of work later.

If you are only going to do your work in 2D, you could use LayOut instead of SketchUp, too.

Dave,

I did consider LayOut too, but based on my quick research, it seemed like it was a better workflow to create things in SketchUp first before moving them into LayOut. I will definitely check out LayOut and see what it’s all about.

As for Default Tag Geometry and Purge All, are these plugins?

Best,
Jp

It depends on what you are doing and how you are doing it.

Yes. Both plugins.

Dave,

Thanks, again, so much for your assistance on this and for answering my questions!

Best,
Jp

1 Like

Dave,

You say to leave edges and faces untagged; however, when I select the edges and face entities to form a group, form the group, then select the edge/face again, these are tagged with the group’s tag. Is that okay? The norm? Or is there something else I should be doing to create groups?

Also, I created two groups; however, one has bounding boxes while the other has no bounding boxes. What gives?

Jp

Create the group or component of the selected edges (and faces if there are any) and then, give the selected group the tag. Leave the edges and faces inside the group untagged. In my version of your model you will see that I made a component containing the edges for the contours and gave that component a tag with a dash style applied to it. If you open that component for editing you will see that the edges are still untagged.

Working this way makes the work flow easier and less prone to errors because you are never chasing the active tag as you ware working unlike the way you have to work in some programs where you are constantly concerned about an active layer. If you make it a habit to leave Untagged active and leave all edges and faces untagged, you don’t even need to know what tag is assigned to the group or component when you are editing it.

Dave,

Thanks! I drilled down to open for edit and see that my groups’ edges/faces are still untagged, but when selected as a group, and then selecting an edge/face will show its group’s tag. So I am more clear now.

One thing I am unable to see where the dash style was applied to the tagged contour lines. I tried looking at the “Styles” box with the Slope Contour tag selected. Where should I be looking at to see what attributes are attached to tags (other than the advanced attribute box within Entity Info)?

Jp

If the group isn’t open for editing, clicking on an edge in the group only selects the group. It’s the same as if you click on a face in the group.

Look in the Tags panel.

Lol. The Tray wasn’t wide enough. Go figure. Just had to widen it a bit to see the rest of the stuff. No wonder I couldn’t remember how I changed the line style in the first place.

Thanks so much!

1 Like

By the way, if you are going to end up sending the SketchUp model to LayOut, you can skip assigning the dashes in SketchUp and just set it in LayOut. Something like this:

No dashes in SU and I’ve removed dimensions and labels.

Dashes added in LO along with dimensions and labels.