Material window is very slow


#1

Hello !

I just bought a new computer. It’s a Gigabyte Aero 15 with i7 6700HQ, 16gb Ram, Geforce gtx 1060 and a flash drive. I assumed it would be enough to make Sketch Up working perfectly.

But everytime I open the material window on the right panels, it take a very long time. Specially when I use materials that I bring from my computer or when I select my model.

I did all the latest update for windows or my drivers, and correctly configured Sketch Up to use my graphic card instead of the processor. I have this problem with the free version and with the pro one.

Did any one had a similar issue, or found a solution ?

Also I’d like to go back to the previous way of displaying windows, because I’m used to it. Is it possible ?

Thank you very much !


#2

When you installed SketchUp on your new computer, did you right click on the installer and choose Run as administrator or did you just double click on the installer file?

Are you referring to the tray? If you prefer the individual windows floating around in different places, you can make individual trays that each have a single window in them. You might work with the tray for awhile and give it an honest try. You can move the tray to a different location if you want or split the windows into different trays. You can also unpin the tray so it collapses when you aren’t using it.


#3

Thank you very much for your reply !

I just double click on the installer file. I’ll try to reinstall it as an administrator and I’ll let you know if it’s work.

Yes I was referring to the tray. When I make individual trays and I put them, for exemple, on the left side of the screen, it goes back on the right every time I open it, and go back to the left when I close it. Is it a bug ? Is it because I didn’t install the soft as an administrator ?

Thank you again !


#4

Double clicking the installer is the wrong way to run it. Right click on it and choose Run as administrator.

Most likely due to incorrect installation. Once you’ve installed SketchUp correctly, you should be able to dock the tray on the left if that’s where you want it and it should stay.


#5

In the installation instructions here:
https://help.sketchup.com/en/setting-up#installing-new
it says

Windows
After downloading the file, follow these steps to install SketchUp:

Log in to the computer with a user account that has administrator rights.
Double-click the EXE install file. You can also context-click and select Run As an Administrator.

It says you can context-click and run as an Administrator but doesn’t say you have to. Are these instructions just wrong? I’m a Mac person, is this just something a Windows user should know needs done?


#6

Yes. Those instructions are incorrect. There’s a post by @slbaumgartner that explains why logging in as administrator does not provide the same installation privileges as Run as administrator. It doesn’t take much looking around the forum to see that this is the common advice and common fix for many of the weird things that get reported. I’ll see if I can find Steve’s post on this.

Edit: That was easy. See


#7

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.