Material RGB Values not mapped to output consistently


When preparing architectural elevations, I am required to show the color applied to each surface (for example an exterior wall could have a specific RGB).
Selecting the correct material color and applying it using Sketchup is no problem. But when it comes to exporting a 2D Elevation, sketchup (and layout) will map the color with a different RGB value; My guess is that the output is being influenced by Sketchup’s global lighting.

If that is the case, then an option to turn off or ignore global lighting when exporting a 2D image is necessary. Otherwise how can my elevations ever show accurate color?
Un-checking “use sun for shading” makes some difference but is still not an accurate color output.

The way I am checking color accuracy in the output file is to load it in Photoshop or Illustrator and sample the color.

In some cases the difference is obvious even within Sketchup - for example, as shown in my attached file, when viewing the colors Gold (255-215-00) and Yellow (255-255-0) the RGB values are quite different yet they almost always look identical in Parallel Projection mode within sketchup. I might be able to accept some difference within Sketchup - perhaps Layout could be the place to add this function (“ignore lighting”)?

Colour Mismatch.skp (19.9 KB)



Try turning on “use sun for shading” and setting the light slider to 0 and dark to 80.

1 Like

Wow, that is a very peculiar workaround but it works! Thank you!

Interestingly I also received a response from Pro Technical Support:

Hi Sam,

Development reviewed this issue and note that SketchUp renderer is not a photo-realistic renderer so things like this can happen when the materials are close in color.

Have you tried to use commercial renderer such as V-Ray, Podium, etc and check the behavior ? You might want to get trail versions of these renderers and see if they produce the desired result.

The SketchUp Team

Except it’s not a work around. It’s the way to turn off the shading that creates the 3D effect since SU is not doing photo-realistic rendering as Yogesh wrote.

1 Like

Sure, but its a peculiar method… (and undocumented?).

Achieving this mode by selecting “use the sun for shading” seems counter intuitive. Really we are wanting to turn off shading .

Setting Light and Dark sliders to values of 0 and 80 also seems a little arbitrary. A checkbox “turn off global illumination” would be sensible in Pro and Layout, I think.

Photorealistic renderers (ray tracers) can use a studio environment/scene and linear tonemapping (with no raydepth) to simulate a “flat” colour output , but that still wont be a perfect match to the RGB code, so rendering isn’t a solution/ It’s also useless for architectural elevations which require edge lines to be visible in the drawing.

Anyway, I’m happy…its working!

I think I was the first one do document this long ago in the Sketchuaction form’s Doh thread.

The only other mention I have seen of this is in an old SketchUp Blog article about creating a poché look in sections, but still get the values wrong - setting them at 0 and 100.é-sectional-views

The way I found the right value was by using the Match color on screen tool in the Material editor dialog and experimenting at what values the color RGB values stay the same, when selecting the same color in the model.

I think a checkbox to disable the shading is a must, so that users could get the proper color value for their section views.

Yes. This is way it’s been done forever. I did this way back in SU3 before SCF existed. I learned about it in the old @Last SketchUp forum.

Are you saying you’re smart for finding out how to do it so long ago? Or are you saying it’s crazy that, after 15 years, there’s still no intuitive way of producing a colored architectural elevation?
I’m thinking the latter. :slight_smile:

I’m saying I learned how to manage the shading a long time ago. Nothing more.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.