Color matching error

Greetings everyone, I’m facing difficulties aligning the colors between the sketch and Vray render. Despite attempting adjustments in Photoshop with RGB values and various methods, the color inconsistency persists. I have attached the values and relevant details; please advise on the issue. Sketchup 2022 .


If you have the right RGB value in sketchup doesn’t mean you’ll get the exact same color in your render. The color will be altered by ambient light, other surfaces surrounding it which are going to reflect the light, or even its own reflection.
The very same way it’ll behave in reality ! play with your hue/tint in photoshop, applied to the whole image or use a material ID channel to isolate this particular texture, or adjust your scene light tints upstream


This kinda stuff is a huge complex topic.

Ultimately your sRGB values are designed to represent a flat colour on an illuminated screen surface and not represent the spectral properties of a surface in the real world, so there are going to be differences.

You are just going to have to eyeball it I’m afraid.

Do make sure to apply the filmic tonemapper in the v-ray frame buffer - this will better handle the colours and at the very least make your render behave a little more like it was taken with a camera.

1 Like

I’m not familiar with that. What does that do? Imitate the look of film?

Kind of, but that’s not necessary its intention - the one that v-ray uses by default is a technique developed by a videogame developer to help make those computer graphics look more film like.
It takes values of both brightness and color that are outside the range of the sRGB colourspace (or your monitor) and compresses them to fit within the range we would see in a typical image.

You can think of the render buffer as being “the real world” and the tonemapper being a piece of film.
The film responds in very specific ways to specific wavelengths of light and produces the image.

Or if you are a digital person, then the reality of it is that the frame buffer is your RAW file - and a tonemapper is one of the parts of a processing stack that happens in camera, in photoshop or lightroom.

Historically you would take your full range framebuffer as an EXR images and process it in photoshop or somewhere manually, but doing it in the framebuffer itself simplifies things significantly.

you want it to be the top layer - above exposure.

It will help prevent that characteristic (of lower quality renders) strange shift of hues and blow outs of white as the values sit outside of the range of a display. It will also change the way darker values appear.



You’ll also see how it affects the distribution of light and colour in these spotlights too.

with tonemapper

the one used by v-ray is fairly simplistic compared to more modern ones, but it still is a must for all but people who are using more complex setups.

1 Like

It’s the same “issue” you see when painting any wall in real life. The color looks different at different times of day in different light and in different settings. Light is complex.


Very succinct!

Looking at the first image in this thread, what is the colour temperature of your Vray lights?

Tell me about it, I painted three rooms the same color, but they are all different due to lighting. One color saved much more effort rather than trying multiple different colors in each room.


Hi , Thank you everyone for you reply

This Render is without using anylights

I have used 6500 scalar with 30 intensity

6500 scalar with 60 intensity

Please guide what instensity and k should I use to achieve that color

The idea of photorealistic rendering is to show the effect light makes when hitting a surface. In real life it never matches a flat sample, especially not in two surfaces at a time with a different angle to the direction of the light.
When viewing a model in SketchUp, you can eliminate the effect of shading so that all surfaces match the colour of the material samples by turning on “Use sun for shading”, turning shadows off and setting the Light slider to 0 and the dark slider to 80% in the Shadows tray.

Hi, is possible to please explain it step by step

Followed the instruction
this is the result


your light is too warm, it needs to be cooler (maybe around 4500K~5500, looks like yours is more around 3500~4000K), cooler means it will have more blue in it.We can see in your very first post it is tending to values with too much yellow

You can either modify the light color directly or change the temperature like this (open gif in a new tab to make it bigger) :

light temperature

Tried changing the values as per the discussion but this is the result

did you change the right light temperature ? if you have multiple lights, they all have to be modified
can you share your file ?

If you don’t want to bother making adjustments in vray, you can also add a photo filter in photoshop and play with it. Superpose your desired RGB to find a match

light temperature PS

My instruction was for the SketchUp view. It has no effect on Vray renders.
What makes your render sort of unrealistic is that there are no visible light sources so the light appears magically from somewhere out of thin air. And the light colour temperature looks like light from traditional light bulbs.

Can you please advice on how can I make it more realistic render what short of light settings do i need to use

Hi, Thank you will send you the sketchup link please check and let me know

I am unable to attach my file please let me know how can I attach my sketchup file

Those sRGB color samples are produced using 6500k as the whitepoint - as such they would only ever match should the light in the model be 6500k