Sketchup Colorspace / Image Import Best Practices


#1

Hello. Perhaps I am overlooking something obvious, but I am having problems maintaining consistent colors between materials specified in Sketchup and those created in image-editing software such as Photoshop.

Here’s a rundown of the issue:

  • Apply a color to a face in Sketchup (for this example, I chose 0005_LightPink - whose RGB values are 255, 182, 193 respectively)
  • Create a swatch (less than 1024 pixels x 1024 pixels) in Photoshop using the same RGB values
  • Save as a JPEG (using default ICC profile: sRGB IECC1966-2.1)
  • Import as image into Sketchup and place that surface next to the face with 0005_LightPink applied.
  • The colors are not the same.

If I then take a screenshot and bring the two colors displayed in Sketchup back into Photoshop, neither one exactly matches the 255-182-193 RGB color values. I would expect this as Sketchup applies shading to surfaces, but the color created natively in Sketchup is not even close.

What colorspace does Sketchup use?

As a designer, I would like to have color-correct textures in Sketchup and not have to resort to the imprecise method of sampling pixels to “match” textures that should (in theory) have the same hexadecimal values.

Where am I going wrong?


#2

Thsi issues was discusses in this thread:


#3

Thanks for the insight.

Beyond a potential change in SketchUp in the future, is there any workaround to this issue other than using all textured surfaces?


#4

Also note that in a SketchUp view, everything is shaded in relation to the direction of the lighting, either from the built-in “lamp” attached to your camera or from the sun.
The effect of sunlight can be regulated in the Shadow Settings tray
In my monitor, the “flattest” setting where the materials painted on the model faces match closest the swatches in the Materials tray is:

  • turn on "Use the Sun for shading
  • turn shadows off
  • set the Dark slider to 100 %
  • set the Light shader to 80 %

Anssi


#5

@roto,

I don’t believe that there is currently any workaround for this issue.
If you look at my Centaurs, I use colour gradients between human skin and horse hide, and I have used plain colours for the gradients, as well as textures in later models.
e.g. Centaur Stallion
In the case that a texture is used for the skin-hide blend, but plain colours elsewhere, there remains that clear and annoying delineation. So the only option is plain colour (and more detail in the model), or all textures - for now at least. It is a shame that the development team didn’t fix this when the graphics engine was rewritten.


#6

This topic was automatically closed after 91 days. New replies are no longer allowed.