Match Color on Screen within SketchUp not working correctly

Match color on screen not working correctly.

I’ve attached a short video showing how match color is not working correctly within SketchUp. This happens on my work computer as well as on many of the computers in the Interior Design lab where I teach. Having this tool work correctly is critical for Interior Designers who are matching many very specific materials.

I wonder what’s different? I did open the chair component for editing since the material I want to match is on the surfaces of the upholstery. It doesn’t have to be opened for editing though.

Like Dave I’m not seeing a problem. Could you reply with the model that includes the chair photo? It’s so I can check if there is anything particular about the image. I have tried with various images, but still not failed.

Thanks for sending in the bugsplats you get. From those I know you use Enscape, I wonder if that could be affecting things.

Match color model.skp (180.3 KB)

I’m uploading this but it happens with every model, every image, every time. And again, I’m noting it on multiple projects on multiple computers in the computer lab. (just FYI…they all also are using Enscpae.)

I wonder if it has to do with the faces being reversed on the chair?

I corrected the face orientation and applied the gray color to the front faces. Things work as expected. Or maybe it does have something to do with Enscape. I don’t have it installed.

Again, its not just this model or this component…its all of them, everytime. So curious since this is also happening in other computers in our computer lab, so it seems it can’t be linked to a hardware problem, or a corrupted model or component. Any other grand ideas?

Probably not a corrupted model/component. The model you shared worked for me as I showed. If the model or the component was corrupted I should have had the same problem.

First thing I would do is update the graphics drivers. Then I would disable Enscape, restart the computer, and then start SketchUp and see if the problem still occurs.

Hi Diane

My feeling would be that there is some kind of operating system or GPU driver related issue causing this (I don’t have this issue either) - the match from screen button grabs the color from anywhere on the canvas that is the image being rendered to your display by Windows.
SketchUp is basically receiving no data back - hence the black.

What happens if you try to pick a colour from outside of the SketchUp window? The desktop for example? Does that also turn black?

Could you run DXdiag and attach the log file?
Open and run DxDiag.exe - Microsoft Support

I’m attaching the the log file here. DxDiag.txt (119.1 KB)

It won’t let me sample outside of SketchUp (when I move the cursor away from the SketchUp
window, the eyedropper disappears…but that might be user error as I don’t normally use the eyedropper that way.)

Also, it seems that SketchUp has to be receiving some data back because again, if I move the saturation and lightness sliders to the right, then I do see the color that I was sampling.

Good point!

ok, so I can see you have 2 monitors

1 connected via HDMI (an Acer monitor)
and another connected via displayport (a dell one)

Just to rule this out - You could try disconnecting one of them (I’d disable the HDMI one) - restart the computer and see if it does it when just 1 monitor is there.

Also, slightly boring/generic advice, ensure that windows update doesn’t have anything outstanding.

Also, head into the optional updates and install anything you see there
image

1 Like

Wow…I almost didn’t try the monitor thing because it just seemed crazy, but disconnecting either of the monitors solved the problem. That’s a short-term fix, but not really practical when I’m working. What technically is going on? Is there anyway to solve this and still be able to use 2 monitors when I"m working?

Anyway, thanks so much for your problem-solving!

Diane