Managing active section cuts of imported .skp files

Has anyone found a solution to Lindsey`s previous post?: Sketchup forgetting active section cuts
Joe has same issues: Section Plane Activation NOT reloading?

Problem:
In a Master file (say a “Site” model), Section Cuts of linked models (i.e a “building model” linked into the site as a component) can be activated/deactivated - so far so good.
However, I cannot manage to keep these settings for long -despite proper scene and styles settings in the Master model, upon reloading, the ‘building’ model`s active section cuts have been altered.

My observation is that whichever section cut was “active” upon last save of the building model WILL “travel through” to the master file. Annoyingly and counter-intuitively, the “inactive” state of section cuts of the “building” model DOES NOT 'travel through" to the site model. In other words, it does not simply suffice to go back to the linked “building” file, fix active cut settings, re-save and reload into the “site” file …

This really destroys my workflow.

Is this a bug?
Am I missing something?
What is the best practice for Architects when working with linked files?

Help is very much appreciated - Thankx for your time!

attached are two test files with all desired settings… but check out how visibility turns pear-shaped when you reload the linked component into the Master file… ugly!

P.S.: i am using SU pro 2020 version 20.2.172 64 bit on a PC200908 MASTER active sections.skp (215.3 KB) 200908 TEST active sections.skp (194.9 KB)

2 Likes

its not a bug, but its definitely a feature they forgot. We are using the software in a Xref mode but SU has not been design this way. But if they could only fix that annoying problem, we would actually be able to do Xref with it. I’m glad to see that more people have this issue. I hope it will create a wave big enough so it catches the attention of the right people.

Talking about Xref, a few years ago, there was an extension simulating Xref files just like Acad does. It was far to be perfect but it was an interesting approach. I preferred the simplicity of only reloading the child file… and the stupid complexity of re-activating section and updating all scene.

Also, SU team need to understand that the Xref method is very often inevitable due to the lack of performance the software suffer. Editing a single building in a site plan with 20 other buildings is simply IMPOSSIBLE without using this method.

Please SketchUp team. This is not a feature request, it’s a missing feature from day one.

1 Like

By the way, I have also explored Lasuapps ‘Cross reference organiser’, it s premise to enable two-way xref- ing is awesome!..but it fails with big files that have heaps of sub-contexts. In combination with their companion plugin ‘Layers Organiser’ it takes just to long (minutes!) for my residential home models that we generated using the ‘Plusspec’ plugin.

Kind Regards.
Henrik

Edit Oct 2020: FYI, new Lasu app version is out.

I don’t actually believe this happened in previous versions… but here I am tonight with the same issue! Multiple active section cuts coming through the import! :rage:

SketchUp team, let’s get on this!

Hallo guys,

I also had this unusual problem, and I discovered that you can skip it if you save the building model without any active section (check for that by the Outliner panel).

Yes AV77, I also incidentally found that out recently.
I created a dedicated “Export” scene - which I activate prior to saving the file.
just one more workaround on the list :frowning: