Magic mouse left and right click changing sides


#1

When I click on anything in SU using the magic mouse and left click it brings up a dialogue box,
Ha seeing it written down I thought let’s try the righthand click and hey ho it works fine. Puzzles my brain it always worked left clicking but it was becoming very painful 3 or 4 attempts to bring up the tool, now one right click and its there. The mouse must be having a transgender crisis.

One other thing every year it comes round for a license upgrade I have 2018 Pro, it starts going haywire, the simplest of maneuvers like connecting an endpoint to another endpoint it doesn’t want to do it but connects just shy of it unless you zoom right in when you can see the mistake, you carry on with the design and wonder why the faces aren’t there. This means endless going backward and forwards on what the inference should be but isn’t doing. Also even when it is on the exact plane a face doesn’t show until you have crisscrossed the face with loads of lines and provided you delete these lines in the correct order hey ho a face appears this is very time wasting frustrating. I am using a mid-2011 iMac with an upgraded SSD drive. But I am going to buy 2017 basic 27" which has oodles of capacity. So we will see.
Has anyone else had a similar experience? But this certainly tries your patience


#2

I can see that that would be very annoying and make SU virtually unusable. I have seen a similar post to yours recently so it might be worth searching the forum for a solution. My setup is similar to yours but I don’t have your issues, so it certainly can all work properly. Have you tried using a different mouse?

BTW, you have not fully filled in your profile to show which version of SU you are using. Such info is really useful to those trying to help out.

PS - is this anything like what you experience: Mouse not aligning to view?


#3

Many thanks for your response the mouse has resumed to normal again but it is ridiculously torturous using it at the moment trying to align a line on a curved wall is pathetic it will do it for a while and then refuse to align to the edge SU Ian using is 2018 pro I got better results on make in the early years

Graham


#4

Although I am not a techie, I doubt the problem is related to SU, not least because the vast majority of people do not experience what you do.

Did you check out the forum thread I included in my last post? It’s just that video cards seem to be a major source of all kinds of problems and if your Mac is 7 years old, it might be struggling with more recent software. If you have older versions of SU still on your system it might be worth seeing if they struggle too. If they don’t, it would tend to point towards needing a newer machine/video card to run current software.

Out of interest, what is your preference setting here (this is mine):

55


#5

My magic mouse would do nothing but right clicks a while back, and it was quicker to simply reboot my SSD than to spend much time troubleshooting. But when you have a trackpad, a magic track pad, a magic mouse, I think I’ve got a few points of potential failure.


#6

24/7 seems to bring a lot of cakes at Boulder HQ?
HB :lollipop::tada::100: