SU main workspace moves itself


#1

SU main workspace sometimes moves itself when I click on one of my right standing window panels. I don’t know why it happens. Any of you knows why it could be happening? Any suggest to solve this problem?


#2

Not without seeing the LayOut file.


#3

Not my system, no mac experience, but isn’t this to do with the sliding desktop issue I have read about fairly often. Something to do with telling mac what desktop to use for what app.


#4

It is in SketchUp not in LayOut, with viewport I was referring to the main workspace. It happens with any file even when I open a new file.


#5

The word “viewport” is normally used in LayOut not in SketchUp and so I thought you were referring to that. Are you still using SketchUp 8?


#6

That is another thing, I mean in the same desktop the workspace sometimes starts to move to the right when I click on the windows panels


#7

I’m sorry for the misunderstanding. I´m using SU 2016. I don’t really know when it started to happen, but I think it ever happened to me when I was using the macbook trackpad, but that was not often, and now I bought the apple magic mouse and it happens also with that mouse. I am not sure, but I think with my other mouse it didn’t happen. I just come to this idea, so I will try with the other mouse and see if it also happen.


#8

OK. See this thread. Especially @slbaumgartner’s post.

Please update your profile. It is helpful to have accurate information there when you need help.


#9

Profile updated. In that post what happens is that the desktop changes, but in my case that is not the problem. What happens to me is this:

It move it self when clicking out of the window, but only sometimes. And I think it has something to be with the apple magic mouse and or the apples trackpad.


#10

It would have helped to see that GIF in your first post.

You are likely right about the Magic mouse and trackpad. Get an inexpensive Logitech 3-button mouse and try that. Just plug and play.


#11

I just learned how to do it, but you are probably right, I should do it at the beginning of the post, so sorry again.

If there is any other suggestion than buying an Logitech mouse, please let me know. I will really appreciate it. :slight_smile:


#12

Get some other inexpensive mouse? Maybe you can even find a used wired USB mouse from a PC. I use an old wired mouse on one of the Macs in the house and it works fine. Just make sure it has a working center mouse button/wheel.

At least borrow a real mouse from someone and try it out. That will help to identify if your magic Mouse and Trackpad are the culprits,


#13

I’d learn how to move around spaces: four-finger side swipe can be handy sometimes when I RDP to a Windows box. Learn to control System Preferences->Trackpad. When I first learned SketchUp, I forced myself to learn cmd-ctrl click-trackpad-down and move to orbit, which replicates the middle mouse button down on a 3 button mouse, and then adding the shift key to be able to pan. It gives you the ability to walk up to any machine and do things quickly.


#14

Hello Barry, what means RDP? And what do you mean with “four-finger side swipe can be handy sometimes when I RDP to a Windows box”? How to orbit with the trackpad using cmd+ctrl, I also learned it some time ago, but thank you for the advice. It is very useful, but if there is a mouse it is much more better to use it.


#15

If some one has the same problem as me, one thing worked for me, so maybe that could work for you as well:
If you look at the GIF you can see that my workspace in the right side doesn’t go until the end of the screen, so I tried to make the workspace larger, so that it occupied the maximum of the screen and after that the problem didn’t happen again, at least until now.

Note: If I use full screen mode the problem still happens, but if I manually extend the workspace so that it fits in the whole screen it stops to happen.


#16

I think the default for space swapping, er full screen is one-less finger than I thought:

So Microsoft Remote Desktop (Protocol - RDP) likes to open full screen by default. I initially hated that, but it’s grown on me so I let it and do the 3 finger swipe.

Glad you figured it out.