Unable to Select objects with my mouse (Mac OS)


#1

All of a sudden my mouse will no longer select objects with the select tool. No box appears either on left pass or right pass. I saw someone else in another forum complain of this and the moderator said it had something to do with a feature on their Windows video graphics card being turned off. I am on a Mac and it is using a NVIDIA GeForce GT 130 512 MB graphics card which (according to Sketchup) is supposed to be just fine. I have Sketchup Pro 2018

Any ideas? Kind of dead in the water here


#2

First things first. It was working and now it isn’t. Correct? Try this. Quit SketchUp entirely. Shut the computer down completely and do a cold reboot. Then open SketchUp and see if the behavior has changed.


#3

Hello Dave, thank you for the quick response.

  1. You are right, it was working fine, now it isn’t.

  2. Your suggestion was my first go to. I had already shut down all programs. Shut down the computer completely, waited ten minutes, restarted and - no joy.


#4

Hmm… Wireless mouse? Batteries?


#5

I would also check the mouse settings in System Preferences. I found in teaching a weekly class, I have to remind students to check these settings at the start of every class as in that environment they keep getting changed somehow. In our case it’s the middle (wheel) button that gets set wrong for SU, but maybe the left button setting is messed up?


#6

What version of OS?


#7

Good Morning Gentlemen. Thanks so much again for trying to help.

OS - ElCapitain - vers 10.11.6 and (before anyone asks) - 2.93 GHz Intel Core 2 Duo Processor, Memory 8 GB 1067 MHz DDR3 - all fine according to Sketchup

The mouse setup suggestion is interesting. It drags and drops objects just fine in Sketchup and all other programs. However when I go to setup and click on Bluetooth Devices it says it is searching for a bluetooth or USB connected mouse and can’t find one. It’s a generic Microsoft USB mouse. Looks like I might have to give up and go to the Apple store to shell out their ridiculous prices for accessories. While I’m here (and going there) is the track/drawing pad worth it for Sketchup?


#8

El Capitan should work fine with SketchUp 2018.

The type of mouse you use shouldn’t matter. If your mouse works in other applications, it should work in SketchUp too.

If you’re using a USB mouse, why are you even clicking on Bluetooth setup?

What sometimes happens is that the select tool isn’t selected and you think it is. The cursor is just the same as the normal mouse cursor pointed arrow, so you don’t notice that it’s not selected. Try just clicking on the select tool in the toolbar again. Using the spacebar to choose the select tool isn’t reliable on the Mac version of SketchUp. You usually have to press the tab key 4 times to get the select tool icon highlighted in blue, then spacebar activates the select tool. Other times it gets stuck and you have to muck about with tab, shift-tab and control-tab to get the spacebar working for select again.


#9

Good Mornin’ McGordon :hugs:. I’m looking under bluetooth devices because everything else was fine and it was the only other option and, sure enough, it says “searching for bluetooth or USB connected devices…” and it is unable to find my mouse. Interesting, no?

I have never used the space bar to go to the select tool, I have always just clicked on it. As I said before, I use it (and can still use it) to click on and drag about objects. It simply has stopped being able to create a window to select items, either on a to the left click drag or to the right click drag.


#10

I thought it wasn’t working at all. If it’s just that it doesn’t show the selection window when you click hold and drag, then that does sound more like a graphics issue.


#11

Try to select 0x for Antialiasing in the SketchUp>Preferences>OpenGL Panel tick/untick Use fast feedback. Set the style to render transparancy faster.

Might help…


#12

For what it’s worth, I have been actively using SketchUp on a Mac for six or so years (using V8, 2014-2018) and have never encountered a case where the Spacebar key on the keyboard does not invoke the Select tool. It is 100% completely reliable for me. I don’t even know what the Tab key does in SketchUp! Doing a quick experiment just now, I can’t tell if Tab does anything.


#13

It depends on which setting you use in System Preferences / Keyboard / Shortcuts / Full keyboard access. If you have it set to “All controls” then when you press tab in SketchUp it cycles through icons on the toolbar. You can cycle through them in the other direction with shift-tab.

When you set it to “Text boxes and lists only”, tab just cycles between text boxes as it says on the setting. It doesn’t muck up the space bar to activate the select tool.

I like to leave it on “All Controls” and just deal with it in SketchUp, but if SketchUp is the only program you ever use or you just don’t like this, turn it off. For me, it is 100% reliable that spacebar won’t work when I open a new file or a previously saved file that spacebar was working in.


#14

Gordon, thanks for the clarification that the unpleasant Spacebar behavior is connected to the Mac’s keyboard configuration. As you might guess, I have my keyboards set to “Text boxes and lists only”; I don’t think I’ve ever even looked at the Shortcuts tab of the Keyboard System Preferences. :slight_smile:


#15

IT’S OFFICIAL! Mike is a genius! That worked. Wonderful. No trip required to the Apple Store to buy their overpriced products manufactured by Chinese fetuses in chains working in suicide-proof cages. Thank you Mike!


#16

I’m glad you got it fixed. You should mark Mike’s answer as the solution.

After thinking about it a bit, I have it set to that too now. I just realised that I was wasting more time in SketchUp than I was saving in other programs (can’t even remember anything in particular I used it for).


#17

So it was a graphic issue, after all. Mind you, the Chinese can build, too!

Construction Simulation Design Program

and since your graphic card Production Status is ended:


let us hope that you do not need them in the near future…:grinning:


#18

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.