MacBook Air crash without Bugsplat report

My MacBook Air repeatedly crash while I’m working on å somewhat complex model. There is no sign of warning e.g. slow processing. I can not identify any specific action that triggers crashing. When I SU crash and freeze with the spinning wheel, I leave it for a while to see what happens, and I can still work on other apps. When I get back to check on SU, “The app is not responding” and I force quit SU. I short while afterwords the whole system goes in black and restarts. There is no Bugsplat report.
I’d be grateful for any kind of help here.

Model: MacBook Air (Retina, 13-inch, 2018)
Processor: 1,6 GHz Tokjerners Intel Core i5
Memory: 16 GB 2133 MHz LPDDR3
Graphics: Intel UHD Graphics 617 1536 MB

Open Activity Monitor and watch how much memory SketchUp is using. Some models can use up a lot of memory. I had one a few days ago that took 170 GB of memory. It did eventually open and I could move around in the model, but then that was on my 64 GB M1 Max MacBook Pro.

If it is simply using up all system memory you would either need more RAM, or find ways to make the model be less complex.

By the way, your subscription lets you use SketchUp 2022. You could give that a try, it did include a lot of fixes for problems that were in the 2021 version. This will give you the Mac disk image:

https://www.sketchup.com/sketchup/SketchUpPro-full-dmg

I am using SketchUp 2022 latest update.
SketchUp with the actual model open, use about 3 GB of total 16 GB.
Without SU open, the same session use fixed memory: 3,14 GB and app memory 4 GB. Shouldn’t there be enough memory for Sketchup here?

How much memory is used when SketchUp is open with a new document? Here is what I see (I have 2020, 2021, and 2022 open):

Check the memory use during the time that SketchUp is not responding.

Would it be possible for us to try your model? You could upload the file using dropbox or google drive, or wetransfer.com.

Sketchup with a new clean document: 255,5 MB
with an earlier version of the same model 718 MB

Somethings must have gone wrong with the model since that version. I am afraid there is something connected to axes. I experienced that some elements became unable to move out of 2 planes. I found out that this could be due to that is was glued. I tried to fix this, but it became rather messy, I guess I am not experienced enough in the use of axes.

Anyway - here is a copy of the model that causes crash.

I see what is causing the performance problems. You have a texture named Impregnert, that is 2400 x 3000, 300 dpi. It’s used in a lot of places. Making that texture be smaller will help a lot. There are a few other things in the model that is affecting performance and ease of modeling. You have Edges turned off, Profiles and Depth Cue turned on. I think you did that because you were seeing a lot of edges, which was happening because you had Back Edges turned on.

You had also changed the field of view of the camera to 6 degrees, instead of the default of 35 degrees. With that more flattened view, and no edges showing to be able to inference off, modeling would have been hard. Having Profiles and Depth Cue on would affect performance a lot.

Here is a copy of your model where I fixed those things, and also changed the Impregnert texture to be 240 x 300. I also purged things that are not being used. The model went from about 12 MB to below 2 MB, and the memory SketchUp uses went from above 700 MB down to 330 MB.

veranda lillehytta 11.skp (1.8 MB)

Thank you very much. This was a great help! I will now try to replicate what you have done on my own file, and maybe I’ll learn something.
Is there a tutorial on how to economize with memory and space in SketchUp? If not, I can suggest that someone competent could make one?

Katya, who was a colleague until the end of last week (she has taken a position in a different company) wrote this guide a few years ago. It may help you:

Thanks a lot, and to Katya too :slight_smile: