Sketchup has started crashing every ten minutes or so - seems to be using a lot of memory

Hello everyone. First time poster and not a Sketchup or computer masterful user by any stretch of the imagination so go easy :wink:

I’m just learning Sketchup as I go along for some work - have been finding it really helpful and perfect for what I’m doing. However this evening the model started crashing every ten mins or so - I just get the mac spinning wheel and no matter how long I wait I have to force quit.

Can anyone advise me on some things to try - I’ve been searching in here and on google but can’t seem to make head nor tails of what’s going on.

I’ve tried restarting and reinstalling. I was using an external mouse but tried without it and still no joy.

Here is the google drive link for the file Level 3 & 5 version 3 Sketchup capacities~.skp - Google Drive

My Mac is 13 inch 2019 pro running MacOS monterey 12.6
1.4 GHz Quad-core intel core i5
Memor : 8 GB 2133 MHz LPDDR3
250GB storage
Graphics : Intel Iris Plus Graphics 645 1536 MB

Just ask me what else I need to tell you (and maybe how I find that information!)

Thanks so much


I loaded your model on my MacBookPro 16" running Monterey 12.6 and after a while of playing around it hasn’t crashed or frozen yet. The SketchUp geometry itself is not very complex (233k edges, 93k faces) though that seems a lot for the simple visible geometry.

Activity monitor shows SketchUp taking 2.41GB of memory, which is probably due to the geolocation images and terrain (BTW, there is a terrain and image patch some distance from the main model that doesn’t appear to have anything to do with it). Check Activity Monitor to see how much free memory you have - particularly if you have other apps running at the same time as SketchUp. Exceeding the available real RAM can cause everything to slow down dramatically. Also, take a look at whether you have autosave enabled in preferences and if so, for what time interval - perhaps 10 minutes? If the Mac is close to its limits, that might be pushing it over.

Thanks for this

SU seems to start when first open only using a few hundred MB of memory in activity monitor and then keeps increasing quickly over 5 / 10 mins up to about 3GB when it crashes.

I just tried turning off autosave which was on for every 5 mins but it just crashed again… I don’t really have anything else running at the same time but activity monitor does show I have 8GB memory available and am using 6.62 with 1.41GB in cached files. Seems like SU is pushing it over the limit . Any tips of saving memory usage on my computer?!

Thanks again for your reply

I just experimented with creating a new file and imported some much more complex objects from the warehouse - my activity monitor shows higher memory usage but doesn’t crash - so I think it must be something to do with that file I linked that I am working on . If anyone has any ideas I’d really appreciate it!

You aren’t using a 3d mouse are you?

Nope - just a Satechi wireless mouse - but tried yesterday with just using my laptop mouse and still crashes on the culprit file

Are you running any “major” SketchUp extensions that might be performing some invisible monitoring of the model and taking some kind of action or doing some kind of calculations? You might try disabling all extensions (via the Extension Manager window), exit completely out of SketchUp and restart it with the troublesome model to see if anything has changed.


I’ll try that - this is what comes up -

Am I ok to press OK to this?!

I think it is OK to disable the dynamic components extension, so long as you are not going to configure or otherwise modify a dynamic component during the experiment.

I’m wondering if the terrain groups are overwhelming your graphics. Since you don’t appear to be using them (the tag is non-visible) you might try unlocking and then deleting the four terrain groups. Of course, if you need the terrain this won’t be the right final answer but it would help to test my theory.

ummmm… how do i do this?!


Still crashing unfortunately ;-(

Thank you for trying the experiment of disabling extensions. Even though the problem remains, I suppose we can conclude that it is not caused by a mis-behaving extension.

The above is from the original post. In comparison:

The above is from a subsequent reply. Can you clarify whether this is a true crash (where the application terminates on its own, “hands off” so to speak), or whether it is a spinning-beachball hang that you eventually force-quit? If SketchUp terminates on its own, do you get a Bugsplat report, or do you get a mac OS crash report?

Another experiment, based on your earlier test of creating a new file with a fair amount of geometry inside it which did not exhibit the problem: Can you try opening the file that shows the problem, Select All and Copy, then open a new file and Paste in Place. Hopefully the crash/hang would not occur while you are doing this. Then quit SketchUp (closing both files) and open the new file that contains all the entities from the problematic file. Does it spontaneously consume more and more memory?


It’s always the spinning wheel which I’ve tried leaving for quite a long time (up to an hour) and always have to force quit. I don’t get a bugsplat report just a Apple crash report

i tried as you described - the model starts at a much lower amount of memory 250 mb - still rising but much slower - however it hasn’t imported all the geo location map items in the copying and pasting process…

do you mean the geo-location terrain I’ve added into the model - if so I definitely need this as I’m using sketch up to mark out infrastructure going onto a specific site…

Geolocation data included both surface imagery and a mesh of terrain height. Everything you drew in your model is placed on the flat image, which led me to think the terrain height doesn’t matter for your purpose. If that is wrong, please ignore my previous suggestion.

Ah right yes i see - that’s exactly correct that I only need it flat - I can see how to toggle the terrain on and off but not how to remove the terrain data from the model - how do I do that?

Turn on the terrain tag, select one of the terrain meshes, click the icon in the entity window to unlock it, and then erase it.