Mac OS X 10.11.6, SketchUp Make 2017 Crashes Immediately when Start Using SketchUp is clicked



Let me apologize for the font of my post. I recognized that this forum parsed markdown and wrote it outside of this editor and simply copied and pasted in. Normally 2 pounds signifies a h2 heading not a red font h2 heading. I didn’t pick that up when I posted it and that is my error.

  • I am a former amazon engineer. I have seen millions of requests from millions of users just within holiday peak hours.

  • I criticized the process not you yet you are criticizing me and passing judgement without fact or data.

  • You can still be successful and also come off as an unpleasant person to your customers.

  • I didn’t comment on timeline or that I was upset you weren’t going to fix it. Again I criticized the process.

  • Do you feel your response helped me understand you or your prioritization better? Do you feel that bringing up the babbage engine added value to the conversation or made me feel that you were an ambassador for me?

The forum guidelines say criticism is welcome and to criticize ideas and not people which is what I did. That obviously struck a nerve with you and you felt the need to bring a condescending tone to the conversation at an attempt to make me feel… bad I guess or new or both. I’m not really sure what your motive was but all it did was make me feel frustration toward the sketchup support system and your inability to accept said criticism.

I will give it time but in the meantime I just reformatted my mac to run sketchup on a case insensitive file system to resolve the issue.


I am not attempting to make anyone feel bad. I simply deliver the facts. I could flip your argument and say the word “rhetoric” is loaded and condescending, or that your questioning our prioritization as if we haven’t weighed this issue carefully seemed incredibly aggressive and personal for a first post.

Look, I’m just here to give you the facts, argue for you internally, and give you workarounds for temporary solutions when I lose those arguments. I gave this thread a short and long term solution. And if you really think you can help us make better decisions, send me your resume.


however, shouldn’t this be denoted in the system requirements?

btw, will upcoming APFS address this issue?


APFS will raise this issue to critical, since APFS is always case-sensitive! I think Barry acknowledged so and admitted that Trimble knows they have to work on it. Since this will be a show-stopper for any Mac user who updates to APFS, hopefully it will get more prompt attention than all the other gripes we Mac users have raised over the years :wink:.

I sincerely hope that very few extension developers have been similarly sloppy about case in file and folder names, else there will be a real catastrophe!


(macOS Sierra, Intel Iris Pro 1536 MB, Sketchup Make User 2017, case-sensitive filesystem)

I have experienced the same problem as everybody here. Cut to the chase. The following steps got Sketchup 2017 Make User running, showing the new document screen (with the jaundiced dude standing on a green plane), and I was able to save that starter document without crashing. (Sketchup had previously crashed in all the same ways as users have documented on this thread).

Open Terminal, or iTerm2, and execute each of the following three $ lines (copy everything after the $)

# You assume all risk for using the following instructions!

# 1. Bulk symlink Sketchup’s .dylib camelCase files to lowercase (this works because case-sensitive filesystem allows concurrence). Skips .dylib files which are all-lowercase to begin with.

$ cd /Applications/SketchUp\ 2017/
$ ls *.dylib | egrep -v ‘lib[a-z0-9-]+.dylib’ | perl -ane 'chop; $n=lc $_; print ln -s $_ $n

# 2. Start with Ruby disabled (as others here have suggested), won’t work otherwise.

$ /Applications/SketchUp\ 2017/ -DisableRubyAPI YES

As such, I am able to run Sketchup. (Dear sketchup devs: you could include similar symlink generation in your build process and be done with the problem).

Once the foregoing was implemented, at first Sketchup crashed a few more times, with BugSplat appearing, but then it stabilised, somehow, inexplicably. Fingers crossed. I haven’t tested much more as yet.

Notes: This problem is caused by Sketchup’s developers naming the .dylib files to one capitalisation standard, then accessing them in code with another. The sort of error a non-Unix or a non-C engineer would make… like a Windows programmer, because Windows has always had case-insensitive filesystems. However, this is a well-known issue around Adobe products on OSX and should’ve been detected by Sketchup devs and dealt with ages ago. Essentially, you are filtering out advanced OSX users who chose the case-sensitive filesystem for compatibility with other unix-like filesystems (rsync, sftp, hello?), only to be burned by a developer who doesn’t know that’s a thing.

-J. Quimbly

Jun 19 23:46:10 dosadi SketchUp[5066]: BugSplatFramework: initWithDatabase: defaultExceptionHandler is set
Jun 19 23:47:43 dosadi SketchUp[5066]: BugSplatFramework: exceptionHandler: shouldLogException name: NSAccessibilityException
reason: “AXSize” attribute unsettable for element: <NSPanel: 0x7fa186dbf020>
mask: 256
Jun 19 23:47:43 dosadi SketchUp[5066]: BugSplatFramework: exceptionHandler: shouldHandleException name: NSAccessibilityException
reason: “AXSize” attribute unsettable for element: <NSPanel: 0x7fa186dbf020>
mask: 512
Jun 19 23:47:51 dosadi SketchUp[5066]: objc[5066]: Class SKTextPath is implemented in both /Applications/SketchUp 2017/ (0x10577ce88) and /Applications/SketchUp 2017/ (0x11d10f090).
One of the two will be used. Which one is undefined.
Jun 19 23:47:52 dosadi SketchUp[5066]: objc[5066]: Class HLRExporterBase is implemented in both /Applications/SketchUp 2017/ (0x123b3be70) and /Applications/SketchUp 2017/ (0x123b99ef8). One of the two will be used. Which one is undefined.
Jun 19 23:50:15 dosadi SketchUp[5066]: assertion failed: 16F73: libxpc.dylib + 74307 [1C9AF716-69DF-359F-85E9-7DFDE362F9A2]: 0x87
Jun 19 23:50:32 dosadi SketchUp[5066]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked


I have the same issue on MacOs10.12.5 with Sketchup 17.2.2554.
Disabling Ruby allow SketchUp to run, but I cannot use the extensions I need.
Also, Bugsplat does not show any user interface at all.


Same issue here, I even tried to ln -s any .dylib file in /Applications/SketchUp\ 2017/ to their lowercase version without success. After linking all libs, then it’s a uncaught exception which is triggered instead of Library not found.



Same problem here, exactly as described: it gets to the start window, click the “Start using SketchUp” and it crashes instantly. I’ve tried disabling the Ruby API and it works, but that doesn’t cut it for me since I need to run certain extensions. I installed OSX as case-sensitive (developer here, that’s just how things are done in my opinion) and recently upgraded to 10.13. I haven’t been using this machine for SketchUp but now I need to (only computer I got).

Any new info I’m missing? Any other ways to fix it (besides formatting, which won’t happen).


EDIT: just to add this:

Error loading /Applications/SketchUp 2017/ dlopen(/Applications/SketchUp 2017/, 265): Library not loaded: @rpath/libifcplugin.dylib
Referenced from: /Applications/SketchUp 2017/
Reason: image not found


You saw above: I went from NeXT case-sensitive to MacOS X case-respecting and learned to live with it and even like it. If you’re that stubborn that you go to a filesystem that you know will have issues, then you complain about it, this forum probably does not have an answer for you. For the record: I agree with you, but when Apple (a) decided to make APFS to include case-respecting and (b) make it the default, I lost a lot of sense-of-urgency to my internal argument.


Update on my previous post: Contrary to what was initially discussed, High Sierra now installs APFS by default as case-insensitive and normalization-insensitive (In case you didn’t know, UNICODE can represent a single glyph in different ways. For example there is a single code for a c with a cedilla but this glyph can also be represented as a plain c followed by a modifier that adds the cedilla! Normalization refers to converting such sequences into a standard form).

So the impact will be the same as before: if you override the defaults to force case-sensitivity you will avoid compatibility issues with UNIX but suffer the same problems with inconsistent capitalization until/unless the Trimble developers clean up their code.


same problem in High Sierra :frowning:
it worked until a minute ago and then it crashed and wont restart. now i cant go back to my project, which is upsetting.

edit: actually i got it to work again by completely uninstalling sketchup, like this:

and then reinstalling the latest version available

thx guys !