Mac OS Sonoma - NO Middle Mouse gesture

Hi,

I know Mac OS Sonoma has been out for a while but i just recently upgraded to it.

Running the latest Sketchup 23.1.341 on this Macbook Pro 16"
Now i’ve realized that this OS does not support “Middle Mouse Click” which is a big part of modeling in 3D.

Is there a fix around or a future update/plan to reimplement something in SKETCHUP to make the
orbit /pan work again? without having to change tools?

Well you’re the first person to realise that… including most of the staff at sketchup that uses macs running Sonoma. you have 14.4 right ? the latest one ?
Besides, macosX has been supporting middle click since… well the 2000’s ?

could it be your mouse ? does it require an update (if it has a specific software) ?

(also, time to update your profile, it still says Catalina. Ahh, catalina, takes me back…)



to be clear, in your title you mention “gestures” and in your message the middle mouse click. you’re talking about the wheel click that gives you orbit / pan tools right ?
not some tactile three-four fingers things ?

I moved the thread to technical problems for now, as it sounds more like an issue than a feature request.

It used to work before i updated Mac OS.

Yes, i just updated to Sonoma 14.4 and using my old trusty Logitech MX Anywhere 3.
Which does have the middle scroll and click.

In the Mac System Settings > Mouse Settings, there is no middle mouse settings…

I thought maybe Sketchup has moved the UI and created a different shortcut for orbit/pan
I really like the middle mouse and spacebar combo for navigating through the 3D space



Yeah, macos removed that parameter some time ago, now it should work as a mid click by default (you can only swap right and left), and it delegates the buttons mapping to the specific apps you have to install.

In your last image, in LogiOptions, you’re looking at point and scroll. But right above (left side) in Buttons, you should be able to give the wheel the mid click.

2 things to try if it’s not working :

  • don’t set up a sketchup mode. or turn it off. I’m using a mx master 2, no mode specific to any application, just try with a global parameter. I’ve seen issues with that in a few games
  • just below your wheel there is a button. by default it changes de dpi, try to give it middle click instead and test. If it works, then your wheel has some issues.


here is my setup, no app specific setup, and middle button mapped to both the wheel click and the central button (I find it more confortable, it’s an actual button, it won’t scroll)

1 Like

Well that worked perfectly.
Appreciate it the kelp!

2 Likes