Mac- Model "Wandering" Off Screen or Jumping When Tools Clicked

Hello,

I am having an inconsistent issue where a model spontaneously “wanders” off the screen indefinitely, requiring me to find the model with Zoom Extents. Occasionally, even clicking on Zoom Extents will bring the model back to center, but still does not stop the image from repeatedly sliding off the screen. Maybe apart of the same problem, I also have experienced a model “jumping” from where I am focused when I click on a variety of tools. This happens regardless of different Mac Mouses that I use or the trackpad of a 2016 MacBook Pro.

In my troubleshooting I have updated to the most recent version of SketchUp Pro 17 and Mac OS 10.12. I have further turned off “use inertia” for my mouse and trackpad. Yes, I have also assured that I haven’t been accidentally glancing the trackpad with my hands, accidentally pressing any effective keys, and made sure that any remote input devices close by could be interfering here.

Please forgive me if this issue is addressed elsewhere, but none of my forum searches matched this problem exactly (or I didn’t use the right search words).

Peace,
Zeigh.

are you running in ‘full screen’ mode?

john

John,

No use of full screen mode. However, every model window that I work with is maximized and I switch often between pages via Apple’s Mission Control “swipe between full screen apps with three fingers” method.

Peace,
Zeigh.

I haven’t seen this myself. So, gathering more info to see if I can reproduce it…

  • Is this happening for all models, a few models, or just one specific model? If some model does it consistently, could you share that model here?
  • Does it happen all the time or just sometimes?
  • Is there any pattern to what you did just before?
  • Do you have anything selected when this happens?
  • What tool or extension is active when it happens?

slbaumgartner,

  • There seems to be no consistency with the problem that I can detect with one model or another.
  • The issue is very erratic in when it presents itself. Sometimes I can go for days without it happening. Computer and/or SketchUp Pro restarts do seem to correct the problem most of the time, but I did experience once where the issue persisted with inside of 10 minutes after a restart of both.
  • There is no pattern that I can see in my actions so far. In fact, I have actually been taking notes on the problem for a few weeks now in order to be a better diagnostician here. The frustration of the issue finally prompted me to report what little I had.
  • There is no consistency with whether something is selected or the tool used.

If there is anything that is occurring the most frequently, it is leaving SketchUp Pro open on the assigned (Mission Control) page and coming back to it to find a model drifting “miles” away from it’s center.

Peace,
Zeigh.

I don’t know if this is relate to your problem, but I had similar issue caused by 3D Space Mouse, that needed to be calibrated (in setting).

Charevir,

My issue occurs when I use a mouse or the trackpad of my MacBook Pro, so I am not sure that your suggestion makes much difference. I have experimented allot with the settings that I can see for mouse control both in SketchUp Pro and Mac OS 10.12. Then of course, reset everything to default in my troubleshooting. However, I have not seen where I could “calibrate” my mouse.

Peace,
Zeigh.

I still can’t reproduce this problem, so I can only offer vague analysis. SketchUp does not move model contents or change the model view spontaneously. It has to receive input via the GUI or a ruby script. Maybe macOS is somehow sending bogus events to SketchUp. But I would expect that to affect other apps too, and except for a hardware defect such as a damaged trackpad I don’t know how that could happen.

I have a similar issue.
I use Mac book pro (Sierra 10.12.6) sketchup 17pro with track pad. I don’t use mouse.
Curser hangs up when I use trackpad some times. It behaves erratically.
Tried to emulate the problem with multiple sketchup full screen windows and the problem appeared. The curser behaves normal when connected to a wired mouse.
in the same session Curser behaves oddly with rest of the system/ desktop space while using trackpad but not with a mouse.
Problem temporarily disappears when system is restarted ( trackpad remains like that if I don’t restart) Tried resetting NVRAM. No use. HELP!

The easy fix would be to use a mouse the way SketchUp was designed to be driven.

I’d agree with @slbaumgartner in that it really sounds like a damaged trackpad. You may not have other apps that do crazy cmd-ctrl-shift hold-thumb-down-while-moving-index-finger to pan… yes that’s a 5 finger gesture, now that I think about it. I don’t know if Apple’s hw diagnostics would test this? They don’t appear to: https://support.apple.com/en-us/HT202731

Could be hardware issue finding problem with otherwise also. Going to replace it.
Thank you

I am the OP and feel your pain. After months of dealing with the issue, I can offer this:

  • Model wandering offscreen is reproducible (when it occurs and until the next restart). On method is to use the measuring or drawing tool in placing a line, then edit the numbers. The model begins to drift as soon as the cursor is in the measurement/length box and you click to change the numbers. Once this condition shows itself, the model also wanders whenever I switch screens via a Mission Control swipe and return.

  • Cursor image flickering. If SketchUp Pro has been opened for awhile (hours/days), I will notice that the cursor image flickers between whatever tool symbol that is currently chosen and the last used one (such as rotate and measure). This condition is inconsistent.

  • Model jumping. The most reproducible example (when it occurs and until the next restart) is when a new tool is clicked from a tool menu bar and the model jumps partially offscreen. You then have to click on the pan tool or similar to get the model back into frame. The issue repeats itself when another tool is chosen.

Most of the time all issues vanish with either a program restart and occasionally a computer restart. There has never been a case where I am stuck with one of the problems mentioned indefinitely. Since my life and work with SketchUp Pro is on the go so much, I really haven’t been prompted to dig in with invasive troubleshooting yet. As mentioned in my original post, I am using a 2016 MacBook Pro 13" 3.1 GHz Intel Core i7 and have installed the most recent versions of Mac OS and SketchUpPro. The problems are regardless of using the trackpad, Apple Magic Mouse 2, or basic wired mouse.

Peace,
Dr. Z.

I can attest to having this very same issue for a least the past year. In that year I have switched from Sierra to High Sierra (including all incremental updates along the way) and also from SU Pro '17 to '18. I am using a 2016 MacBook Pro 15" 2.9 GHz Intel Core i7. I have seen the problem occur while using the internal trackpad, magic trackpad 2, and magic mouse 1.

Frustratingly, I have not been able to reproduce the problem. However, one situation that it seems to occur somewhat frequently is when attempting to export a model. I will adjust the view to my liking, click File > Export, and suddenly the model will pan itself off the screen behind the export dialog box. These instances are especially frustrating, because if you are attempting to export a Jpeg or something like that, you are not sure if you are exporting the view that was present before initiating the export process, or the blank background visible after the model has panned itself off the screen.

I truly hope that this can be resolved as I use SU for work many hours daily. It seems like we don’t see the kind of application maintenance & bug solving from the SU team that we see in other applications we pay for, such as the Adobe Suite of products. This feels like a bit of a slap in the face as a working professional who is paying for the software and attempting to get the best performance possible from it. It is a wonderful product that just needs some additional attention to these small details. More frequent maintenance releases would go a long way in my opinion to make this feel like a product whose creator values its user base enough to fix problems that are clearly apparent in the software. I will end the soapbox speech there for fear of not appearing at least somewhat grateful to the SU team for producing what truly is an invaluable tool.

4 posts were split to a new topic: Measurement information is no longer static when using the Tape Measure tool https://forums.sketchup.com/t/measurement-information-is-no-longer-static-when-using-the-tape-measure-tool/67456

I am having the same problem with wandering when I click a toll menu on a 2013 macbook pro, OS 10.12.6 and SU 2017

I thought it might be my apple magic mouse (the electrostatic touch of the ouse) so I switched to a Logitech USB mouse. Unfortunately, same problem continues. Just upgraded to the latest version of 2017 and so far no trouble. We’ll see if that lasts.

I have the exact problem. It seems like it is an infinite panning, in the opposite direction to where I click outside of the sketchup window. It happens both when I work on two monitors and when I work on my laptop alone.

This sound like the →"pan border" issue that has been there almost forever. It is not due to a faulty trackpad (but more likely to trigger) because it can be reproduced by mouse. Maybe it is an unfortunate event handling design when the pointer moves over the edge between viewport and UI.

Ensure that the button pressed state is properly released. On a trackpad you can do a superfluous extra tap in the viewport after releasing the finger, just to make sure the drag action is completed.

I’ve been using a mouse and to check that it wasn’t just the mouse, I’ve used my trackpad and several other mouse types and the issue still occurs. I’ve noticed that it happens after i’ve orbited the model, then clicked outside the window, it will start panning indefinitely. Sometimes when I orbit in another direction, the panning does not happen.

Try going to System Preferences->Universal Access->Mouse & Trackpad, and disable the trackpad when a mouse is present.