[Mac] Can't open SketchUp, can't uninstall


#1

I downloaded SketchUp Make yesterday - it made 3 separate files in the finder: Layout, SketchUp and StyleBuilder. I was able to open the “SketchUp” file yesterday and start noodling around. Today, if I double click on any of those files, it shows the icon on my dock, but nothing actually opens.

So I thought maybe I didn’t install it right, and have been trying to delete in order to reinstall. The problem is, when I drag the files to the trash, it says "The item can’t be moved to the trash because it can’t be deleted."
Also, in the finder it shows up under “Devices” as well as files. So I just tried to download it again, and now there are TWO of the exact same SketchUps in my Devices.

Have I totally messed this up? Any advice?


#2

Exactly what steps did you follow to install SketchUp? The download should be a .dmg (disk image) file. You double click this and a license terms dialog should appear. When you accept, another dialog should open with a SketchUp icon and an Applications folder icon. To install, you drag the SketchUp icon onto the Applications folder icon in the dialog. The SketchUp, Layout, and Style Builder apps should appear in your Applications folder. After the installation completes, you can eject the dmg from your Desktop. If you did something else, SketchUp is probably not installed correctly.


#3

Thanks for your reply!

I think I did botch the install the first time around. I couldn’t get the Finder screen to open, so I dragged the SketchUp icon onto my desktop and then moved it to the Applications folder once I got Finder to open.

The second time though, I put it straight into Applications.

Why can’t I uninstall either copy though, to start over fresh?


#4

what happened when you ejected the dmg’s?
did you still have folders in Applications/SketchUp 2015 folder?
john


#5

Both the .dmg files from the two times I installed are in my trash bin. When I try to empty it, there is a message that says "The operation can’t be completed because the item “SketchUpMake-en 6.06.46 PM.dmg” is in use."
I quit SketchUp before I did that…?


#6

Ctrl click trash should work…

or do a restart then empty trash…


#7

Thanks!! Restart & empty worked. Should I try to erase one of the SketchUps now?


#8

can you do a screen capture showing Sketchup in Finder, it should look something like this…


#9

Just went to do that and SketchUp is NOWHERE to be found! How did that get deleted just by deleting the .dmg’s? I thought they were sort of superfluous after install!

Guess I will try to install correctly this time!?

I appreciate your time, John :slight_smile:


#10

you never installed it, you where running from the dmg, as I suspected…

re-read Steves advice on reinstalling…

after you double click the dmg, wait until you see two icons with an arrow in between…

drag SU onto the Applications Folder icon in ‘that’ window…

good luck


#11

Thank you!! All set - just one last question: Is SketchUp supposed to show up in “Devices” also?


#12

click the eject button after the instal is done…

i.e. NOW…


#13

Thank you so much!!! :heart_eyes:


#14

I guess you should tick the topic as ‘solved’