I Quit SketchUp and went to start it again but only opens download page from icon

Hi, I have only recently bought SketchUp Pro 2019 from MC2 Design Ltd. I downloaded it and it worked really well. Then I quit it on my MAC and when I went to start it again from the logo it just opened the download page again. I am very new to SketchUp and keen to start learning and I am mow worried I have been scammed. Does anyone know what I can do?

Thank you

Just a guess but it sounds like you didn’t actually install SketchUp on your computer.

What logo? Was it in the email?

A couple of things I have seen that could lead to similar symptoms; Some people run the application from the disk image file, and others copy the .dmg file to Applications. Either one wouldn’t work out too well.

You download the dmg file and double-click it to mount the disk image. In there is the actual SketchUp 2019 folder, and an alias to Applications. Drag the SketchUp folder onto the Applications alias.

When it is finished copying, select “Eject SketchUp 2019 (English)” from the Finder File menu.

Go to Applications and find the SketchUp 2019 folder, and go into it. Open SketchUp. You will see its icon appear in the Dock, you could move that to another place in the Dock, or right-click on it and in Options choose to Keep in Dock. That way the icon is there even after you have quit SketchUp, and clicking it will open the right file next time.

Hi,

Thank you for your replies. The logo was in the dmg file folder.

I have dragged the SketchUp 2019 folder into the applications alias and it put it into the Applications folder. Which when opened in applications its has LayOut, SketchUp and Style Builder in but when I click on SketchUp it still comes up with the message “SketchUp” is an app downloaded from the Internet. Are you sure you want to open it? and then opens the download page again on SketchUp - https://www.sketchup.com/download/all?from=partner

Do you have any other ideas please?

This has now worked! Thank you for all your help.

What did you do to stop it taking you to the web site?

I think it was just not installed properly, then when the message popped up I was able to say open and it opened SketchUp.

This topic was automatically closed after 186 days. New replies are no longer allowed.