Install problem on Mac

I installed SketchUp on my Mac (OS 13.0). It takes forever to come up, but seems to work fine. However, when I delete the .dmg files from my downloads folder or the “disk” files from my desktop, SketchUp disappears. I don’t want or need my downloads or desktop to be cluttered witth these files / images. What can I do?

I use sketchup on a Mac, and never had that problem, why don’t you just create a new folder to file the installers.

Installing SketchUp | SketchUp Help

Doesn’t work. When I try to delete the “installer” I get a message that SketchUp is running and the “installer” can’t be deleted. When I close SketchUp and delete the “installer”, SketchUp is no longer available.

Thanks, but that is what I am trying to avoid (if I can).

that usually happens when you run sketchup from the installer. The software dissapearing when you kill the dmg, and taking ages to load up.

Can you confirm you actively copied the whole sketchup file to your application folder ? and not simply open the dmg / run the sketchup app from there ?
you HAVE to copy the whole sketchup folder into your application folder. no way around.

(see screen grab, did you physically drag the SU folder to the app folder ?)



What ateliernab said is likely to be the problem. SketchUp does open very slowly if run from the disk image.

When you have copied the folder to Applications, and gone into Applications/SketchUp 2022, to open SketchUp, look in the Dock to see what SketchUp icons appear. The one with a dot under it should be the version that you just opened from Applications. If you see another icon it may be pointing to the version on the disk image. You would want to drag that one away from the Dock, to make sure you don’t accidentally open it again, because doing that would re-mount the disk image, and run SketchUp from there instead of Applications.


I did drag the image to the applications folder. The app appears in my applications folder after I drag it over. Here is the sequence. 1) Nothing in my applications folder. Screenshot 2022-10-28 at 11.00.22 AM

  1. go to download.
  1. click on download under Mac OSX heading
  1. download takes place
    Screenshot 2022-10-28 at 11.04.32 AM
  1. move to applications
    Screenshot 2022-10-28 at 11.14.38 AM.pdf (949.2 KB)

Here it is in applications
Screenshot 2022-10-28 at 11.21.17 AM

When I open the file, this is what I get.

Still doesn’t look like it’s installed correctly to me. SketchUp 2022 should be inside of Applications

It looks to me that you aren’t doing the installation correctly. The downloaded installer should be a .dmg file. Leave that file where it downloaded; DO NOT move or copy it to Applications!

In Finder, open your downloads folder and double click the dmg to mount and run it. You should see a disk image on your desktop that looks like this

Screenshot 2022-10-28 at 2.58.48 PM

and a dialog should open that looks like this

In that dialog, drag the SketchUp 2022 icon onto the Applications icon as indicated by the large gray arrow. After a moment you should see a popup about copying files. When that closes, close the installer dialog, and then right-click and eject the disk image.

SketchUp, LayOut, and StyleBuilder should now be installed in your Applications folder and should run correctly.


@slbaumgartner is correct, you are going astray in step 5. Drag the SketchUp Icon into the applications folder that is right next to it inside the installer window. Not into the dock or anywhere else, otherwise you are only placing an alias pathway to the original, not the actual program files, this is shown by the small black arrow that is added to icon, the thing you have in your application folder only an alias connected back to the dmg.


(endlessfix was faster, but here is my screenshot)

I concur, here you’re creating an alias, so a shortcut. the shortcut leads to the app inside the installation archive, as we mentioned, hence all your problems
Same way, if you just add it to the dock at the bottom, you simply put a link to the dmg installer file.

In your step 5, when you “copy into application” you shouldn’t copy it anywhere across the screen. just on the “application” folder right of the “sketchup file”

If it still doesn’t work, and you have several users on your computer, install sketchup as an admin. Not being an admin might prevent you to install stuff.

This worked, thanks!