Loss of WebDialog Functionality in All Extensions, 3DW and EW


#1

After downloading Sketchup 2015 anything that uses a pop-up interface such as the 3D/Extension Warehouses as well as any extensions using pop-up interfaces do not function. My firewall is not blocking Sketchup, I’m not getting any internet connection messages from Sketchup, Internet explorer is up to date, I’m running Sketchup with full administrative privileges, yet the 3D Warehouse pops up blank, with 4 hyperlinks that do nothing. The extension Warehouse will allow me to search extensions but upon clicking download goes blank. (Shown in red box)

And any extension that uses pop-up interfaces, for example the stair tool or any other geometry generating tool in the 1001bit tools extension (which is up to date and compatible), will show the interface but the fields that will normally have default values are left blank. Filling the fields and pressing build (or exit) does nothing. (Shown in green box)

Another example would be the grass generation extension ‘Fur’, which should have two tabs called “Main” and “Detail”, respectively, as well as sliders for the values of the fur (size, length, etc.) but instead, is missing these parts of the UI and does absolutely nothing. (Shown in blue box)

The same goes for all other pop-up extensions such as Solid Inspector, 3darcstudio Tree Maker, and any extensions drop down menus show up blank. (Shown in purple box)

I revisited Sketchup 2013 to see if it was having the same problem, but any compatible extensions as well as both warehouses worked perfectly, so it is solely Sketchup 2015 that is experiencing this.
It seems to be something not allowing pop-up functionality within Sketchup, but what else is left to check? I’ve reinstalled Sketchup and all extensions tested individually to no avail.

I wanted to include pictures for all of the above mentioned issues for reference, but as a new member can only post one picture. I put them all together so please excuse my lack of photoshop skills. I don’t know how else to explain the problem or ask for help as it covers many aspects of sketchup and there are no topics that I have found anywhere that are remotely similar to my problem. I’m at my wits end with this and would really appreciate any input as to what I could check that is causing this. Thank you.


#2

Russel, these are called **WebDialog**s. On Windows WebDialogs use the Microsoft IE WebBrowser Control.

(1) Is your Win7 up to Service Pack 1 ?

(2) Browser Emulation for WebDialogs
EDIT: I tested running SU8 & SU2013 and they do not reset the emulation setting mentioned below, simply by running. It is the installers that make this setting.
Close SU2013, if open.
Open and close SU2015 (so it updates values in the Registry.)
Re-open SketchUp 2015, and then open the Ruby Console. (Window > Ruby Console)
Paste in the following (all 1 line) into the console input box, and press ENTER:

%x{REG QUERY "HKEY_CURRENT_USER\\Software\\Microsoft\\Internet Explorer\\Main\\FeatureControl\\FEATURE_BROWSER_EMULATION" /v sketchup.exe}

… and paste the resulting DWORD hexadecimal value here.

FYI: Mine is set to 0x0270F, which is 9999 decimal. It means (basically) run WebDialogs in MSIE ver 9 Standards Mode. (See MSDN for more info.)


Webdialog Win10 IE11 CSS
#3

The other thing I’d ask is did you Run the installer with elevated privileges ?

See the instructions here:
Installing SketchUp: http://help.sketchup.com/en/article/56085


#4

Thank you so very much for your quick reply, Dan.

  1. System Info shows 6.1.7601 Service Pack 1 Build 7601

  2. I got the first half, but am a little lost on which DWORD value I need to be inputting after I press enter in the Ruby Console. Is this left to personal preference as to which version of IE to run WebDialogs in?


#5

I can’t say that I did run the installer with admin priveleges. I will reinstall.

Edit: Scratch that. The installer shows the administrator shield icon and asks permission when opening the installer.


#6

No not really. It is set by the SketchUp Installer, based upon what browser functionality the SketchUp Team wishes to support for WebDialog inside SketchUp. It has a lot to do with the what nifty functionality they are promoting for the 3D Warehouse, the Extension Warehouse, MatchPhoto etc.

I have toyed with the setting a bit, but it does not do ME much good, as I have to test extensions with “out-of-the-box” settings, like the endusers have.

(I actually have several specially named attributes under that key, so I can set the value back to older values, when testing extensions under older SketchUp versions.)


#7

My apologies! It returned an empty string, so I will do a reinstall and report back. Thank you.

UPDATE: No change since reinstalling. Is there maybe some registry files that aren’t being deleted between installs? If It’s solely the installer causing this then I’m at a loss, as I’ve downloaded a fresh installer and made sure to run as Administrator.


Trouble with 3D Warehouse_Get Models
#8

@russelb923

  1. Please confirm you have followed all the steps listed in http://help.sketchup.com/en/article/3000056

  2. Please ensure that Javascript is enabled in IE (see http://www.enable-javascript.com/). The simplest choice is to set your security in Internet Explorer to Medium which goes above and beyond enabling Javascript. To set your Security to Medium in Internet Explorer you can open Internet Options, go to the Security tab and adjust the slider to Medium and then uncheck the Protected Mode. Be sure to restart SketchUp after making your changes

  3. You can also try to delete cookiejar.xml and session.dat, if present, from C:\Users\username\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp

  4. Please ensures that cookies are enabled for *.sketchup.com and *.trimble.com


SketchUp does not see internet connection even though IE is up-to-date and using Windows 10
How to use SketchUp Make 2015 after Pro Trial expires?
#9

Hi, Yogesh,

Thank you for the tips. All steps completed, unfortunately still no change in WebDialog function.


#10

“Medium-high” (= default) should be sufficient.


#11

@DanRathbun Any other ideas? I have searched through every WebDialog problem thread I could find, I don’t know what else to do. Your help would be much appreciated.


#12

You never said what version MSIE that was “up to date” ?

I have a batch script you can use to set the emulation, but I totally erased that registry attribute and both 3DW and EW sites work fine for me inside SketchUp (but I’m running MSIE 11.)


#13

You can test for javascript from inside a WebDialog…

Open SU menu >> ‘Windows’ >> ‘Ruby Console’ and copy/paste this code and hit enter/return…

 dlg = UI::WebDialog.new("Javascript Enabled?", true,"enabledJS", 900, 641, 150, 150, true)
 dlg.set_url "http://www.enable-javascript.com"
 dlg.show

it should show this message

Javascript is enabled in your web browser. If you disable JavaScript, this text will change.

if not the instructions are next item on that page…

john


#14

Apologies, I meant that I was running the latest version, IE11.


#15

Ruby Console showed “true” but did not show this message:

It did however open a browser window within SU explaining how to enable Javascript on numerous browsers. To get the above mentioned message I had to paste the URL into a web browser outside of SU. Either way, It appears Javascript is running.


#16

It does not sound like Javascript is running in the WebDialogs.

This other user had the exact same issue, and he solved it:


#17

Unfortunately, changing security to medium has had no effect on my issue.

EDIT: I visited http://www.enable-javascript.com on both IE and my default browser, Chrome, and both showed javascript as enabled.


#18

What security package are you running ?

I am running Comodo and it is really aggressive at stomping on installers while they are trying to do their install tasks. I cannot walk away. I have to sit here and watch the lower right corner of the screen for Comodo popup queries. If I don’t answer the questions quickly enough, Comodo will sandbox tasks, and quarantine utilities, etc. and the install will happen correctly.

Anyway I am wondering if you have a similar issue with your security package.

You could check the logs in Event Viewer, or the Temp directory for the sketchup_install.log, see if anything in them indicates issues.


#19

Where would I check which security package I am running?


#20

UH… you should know this.

They have names like “McAfee”, “Norton”, “AVG”, etc. The often have a Firewall as part of the package.
(Some don’t like AVG Free, and we’d use the built-in Windows Firewall with that.)

ADD: There is usually a tray icon in the lower right of the taskbar, for whatever AV/Security package you’re running.