Webdialog Win10 IE11 CSS


#1

Hi Everyone,

First post here. I have a topic that I know has been discussed, but as far as I have seen, has not been resolved. Let me preface the following by saying that everything worked fine until the Windows 10 upgrade, so I realize this may not be the responsibility of the SketchUp community to even respond. Nevertheless, thanks in advance for any help you can offer.

I am running SU2016 Pro on Windows 10 and IE11. My graphic card is an NVIDIA Quadro 4000.I have 32GB of RAM. As previously mentioned everything worked fine until the Windows 10 upgrade came along. That is when I began to notice problems with SOME SU webdialogs. The CSS wasn’t rendering properly. Not in all webdialogs of extensions - just a couple key extentions, namely Skalp and Skatter. I have reached out to Guy at Skalp, to no avail, although I think he really wanted to figure it out. He just didn’t know why there would be a CSS problem (which he diagnosed). I have checked all of the settings in IE11. I have double-checked that I have the latest version of Java, and that it is enabled in IE11. Using Ctrl+L in the SU webdialog and browsing to https://www.whatismybrowser.com/, I see that something (compatibility mode?) is making that website think I’m running Windows 8 with IE8. So weird, right? I am perplexed and so far disappointed that I am unable to use those to ground-breaking plugins with Windows 10 and IE11. Has there been any developments on this subject that may help me out? I know I must not have tried everything, and that Win10 + IE11+SketchUp + Skalp (and/or Skatter) works fine for someone. I would love to hear from those who are not experiencing any problems, if nothing else!

Could it be my security package? I’m running Norton360 AND Iobit Advanced SystemCare 8.4 Pro.

I have attached a screenshot of my SU2015 Pro for reference (having the same issue). THANK YOU!!!


WebDialog not loading jQuery in Windows SketchUp 2016
#2

that looks like you have javascript turned off for IE… [ not the same thing as JAVA ]

do a search for how to turn it on, I use a mac…

EDIT: I just tested and it is the css that being blocked…

@jiminybillybob my be able to advise better…

john


#3

From what I see in your screenshot, javascript IS running (otherwise the input fields would be empty).
But as Guy stated, the CSS is not loaded for some reason.

What happens if you open
C:\ProgramData\SketchUp\SketchUp 2016\SketchUp\Plugins\jbb_skatter\html\skatter.html
manually with IE?

Thomas


#4

Thanks John. I’ve enable scripting in IE settings, but maybe I missed
something?

Gregory F. Shue

Shue Design Associates
700 Ocean Blvd W
Holden Beach, NC 28462
(910) 284-1946
www.shueda.com

Sent from my smartphone, so messages may be short and/or contain typos.


#5

Works great when I open the html file, even in Chrome.

Gregory F. Shue

Shue Design Associates
700 Ocean Blvd W
Holden Beach, NC 28462
(910) 284-1946
www.shueda.com

Sent from my smartphone, so messages may be short and/or contain typos.


#6

@jiminybillybob

I just found this on stack exchange…

The compatability meta tag MUST be the first meta tag

john


#7

I just re-checked the html in IE11, and I can’t say it works "great,"
although it certainly looks better than in SketchUp.

Gregory F. Shue

Shue Design Associates Inc.
700 Ocean Blvd W
Holden Beach, NC 28462
Phone: 910 284 1946
g.shue@shueda.com
www.shueda.com


#8

@shueda what is your IE Tools >> Compatibility View Settings set to…

Press Alt + X to open IE Tools Menu
Select Internet Options > Advanced Tab
Under Browsing
Check "Automatically Recover from page layout errors with compatibility view"
Click Apply, Ok

Alt + T opens Menu in Command Bar on Windows Desktop
Tab down to Compatibility View Settings using Down Arrow key
Press Enter
You can add websites to compatibility view by typing the url and clicking add
Or, under the window select "Display all websites in compatibility view"
Click Close

it seems that can override any meta tags…

john


#9

Could you open the html file in notepad and replace this :

<head> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"/>

by this :

<head> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

(it just changes the order of the lines)


#10

John,

“Automatically Recover from page layout errors with compatibility view” is not an option that I am seeing in IE11. Also, Alt+T doesn’t do anything on the Windows 10 desktop, unless I’m doing something wrong…

Thanks so much for the assist,

Greg


#11

I edited the html in notepad++. Haven’t seen any change yet, although I haven’t restarted the PC.


#12

Anyone from Trimble have a clue?


#13

I tried to reproduce the problem on windows 10, but i can’t reproduce it.

Guy


#14

Here is a screenshot of skatter.html in IE11. Looks much better than in SketchUp!


#15

I don’t have a PC so I was just surfing for potential solutions…

Click here and see if this makes any sense

john


#16

Notice at the bottom there is a popup that informs you that IE11 has blocked some content ?


#17

that’s probably the js call to skp:
Safari won’t even open the page at all with js enabled, because of it…


#18

@john_drivenupthewall, yes that makes sense.

So you had upgraded from Windows 8.x ?

I just noticed that installing SketchUp 2016 did not yet change SketchUp’s Browser Emulation setting. (On my machine it is still set to emulate IE9, and that is what CTRL+L and loading “whatsmybrowser” test page shows.)

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

Mine is still set to 0x270F (9999 decimal), which is emulate IE9.

22B8 (8888 decimal) emulates IE8.

Try setting to 2AF8 (11000 decimal) or 2AF9 (11001 decimal) for MSIE11 emulation.

ADD: see this thread post for more info:
Loss of WebDialog Functionality in All Extensions, 3DW and EW

EDIT: I just tried changing to emulation 2AF9 (11001 decimal) for MSIE11, re-starting SketchUp, and then retrying the “whatsmybrowser” test page, and the box showing “compatibility mode” is gone, and just MSIE 11 under Windows 7, along with “Your browser is up to date” message.


Now we’d think that a HTML page’s X-UA-Compatibility setting would override, but maybe is doesn’t ?


Are photo textures no longer a feature?
#19

the articles I found said that for ‘Intranet’ meta data is overridden…

maybe WebDialogs are seen as such?

john


#20

Unfortunately, editing the registry and restarting has had no effect. Any
other ideas?

Gregory F. Shue

Shue Design Associates Inc.
700 Ocean Blvd W
Holden Beach, NC 28462
Phone: 910 284 1946
g.shue@shueda.com
www.shueda.com