Loss of WebDialog Functionality in All Extensions, 3DW and EW

Oh! an AV. I thought you meant a certain native Windows security package, sorry.

I’m currently just using Windows Firewall as my HitmanPro AV was reading too many obviously safe files as viruses, looking to try something else. So, nothing impeding the installer at the moment.

that message should show in the WebDialog, not Ruby Console…

if it doesn’t, then WebDialogs do not have javascript enabled, mine looks like this…

post a screen shot if you get a different message…

EDIT: I don’t understand how Webdialogs work fine in SU2013 but not SU2015…

OK, it looks like you do not have javascript enabled for the version of IE used by SU…

@DanRathbun do you get the full ‘enabled’ message if you run the snippet?

I get the enabled message in IE web browser if that is what you’re asking…

EDIT: I see now you were asking Dan, not myself. sorry

Yepper. I have no problem running Javascript. The EW and 3DW pages work fine inside SketchUp for me.

Our systems are similar, except his graphics are newer and better than mine.

@DanRathbun [again, sorry @russelb923 ]

when SU started adding it’s own User Agent string, did it require any special security settings to use javascript?

thinking out loud…

Not that I remember.

@russelb923 Do you know how to check the Internet Options and set “sketchup.com” as a trusted site ?

Yes, this was done already.

Well, sorry, this is a tough nut to crack.

I appreciate your help, anyway. I just don’t get how all the tests contradicted what is actually happening.

Well one test I’d do is eliminate the Windows Firewall. Turn it off completely and try again.

If things work, it’s the culprit. If not it must be in the IE Internet Options.

That was already tried as well. Went ahead and did it again for sanity’s sake. Still no change… I find it odd that IE browser shows the ‘enabled’ message on http://www.enable-javascript.com, yet the same test within SU the WebDialog shows instructions on how to enable.

Could anyone who gets this issue send me their cookiejar.xml document? I’m helping with a SketchUp / Autism camp this week, and on a cheap loaner Thinkpad that one of the kids borrowed, we can only download 2-3 things before the screen goes white.

Fix: delete cookiejar.xml. Repeat.

I’m not sure why the 2015 cookiejar.xml would mess things up or get messed up, but it would explain why 2013 would work and 2015 wouldn’t.

It’s located in \Users\YOUR_NAME\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\


Leaving for work but I will send you a copy of my cookiejar.xml when I get the chance.

Tried this solution a few days ago to no avail. Thanks for your input, though.

OK, we’ve discovered the issue today when I was able to get 2 crash stacks to show what people are getting. It appears that some security setting happens that disables javascript. We were able to also repro the issue where only

shows up on the page. Please check security settings for javascript and embedded apps with IE. Thanks for you’re help.

Not sure what there is left to check, I do not use IE as default so I don’t believe I have any embedded apps. Are there some native apps I should be aware of/check settings for?

Also, what was done to reproduce the issue?

You could turn off phising filter (whatever it is called,) … I have not used IE in so long I forget now. (Been a Chrome guy for years now, and much happier for it.)

Let me check quickly… (switches windows, starts IE11…)


(1) one the toolbar there is a “Safety” menu. Start by being sure all those things are off.
(Ie, ActiveX filtering, Tracking Protection, Do Not Track, & SmartScreen filter.)

(2) toolbar > “Page” > “Compatibility View settings
Be sure that there is no entry for “*.sketchup.com

(3) toolbar > “Tools” > “Pop-up Blocker
Either “Turn off Pop-up Blocker” (submenu item)
or “Pop-up Blocker settings” (submenu item launches dialogbox)
You can add “*.sketchup.com” as an allowed site, or…
at the bottom of the dialog you can change the setting to:
“Low: Allow pop-ups from secure sites”
(This likely means https:// protocol, which covers 3D Warehouse, but the Extension Warehouse has a http:// url. ?)

(4) toolbar > “Tools” > “Manage add-ons” (submenu item launches dialogbox)
It will, by default, show only currently loaded extensions.
Change to “All add-ons” in the “Show” drop-down list at the middle-left, at the bottom of the “Add-on Types” list control.
(Select unneeded extensions and click “Disable” button in lower right corner.)

Disable javascript in IE on PC or Safari on Mac and you’ll see the same thing. The problem is on PC that it works sometimes, then intermittently fails and then continues to fail.

Another strange solution was Comcast: 3d Warehouse not working - #5 by annie_n