Popup windows not displaying properly

When using SketchUp Make 2017(in Win7 64bit), anything that opens a popup (Extension Warehouse, etc.) does not display the popup contents unless the window is moved. I do not have this issue in Make 2016. I have popup blockers disabled, the popup does appear, it just isn’t “painted” unless a refresh is forced by moving the window.

Is there a registry entity or browser setting (latest Firefox) that needs to be set/reset? As said, no issue in Make 2016…

Kinda’ frustratin’… even worse if I’m just being dumb… :wink:

I’m not seeing it on my Win7 box. Do you get the toolbar at the very top of the window that has this:

And can you click on the house to refresh, or is it completely blank?

I get the toolbar, sometimes the window is shaded with “loading”, otherwise blank. If I use the mouse to grab the toolbar and move the window, it immediately loads. Clicking the house does nothing.

same problem with any dialog popups. Can’t enter text until I move the popup.

Does 3DWarehouse load properly? 2017 uses Chromium for Extension Warehouse and SketchUp Warehouse, so your IE settings for blocking popups shouldn’t affect anything here. Do you have system settings that might prevent this?

Same behavior with 3D Warehouse. Nothing until I move the window. All Popups generated by Make 2017 behave that way. Make 2016 on the same machine does not exhibit this behavior.

Hardware Issue > video card or possibly drivers.

1 Like

While SU17 includes Chromium for web access, the default OS browser, IE for Windows and Safari for Mac, still provides webkit tools in SU17.

Time for baseline maintenance. Is IE updated to latest and greatest? Check IE security setting and clear cookies and cache. Open IE > click on gear in upper right corner > Internet options > General tab > Browsing history > Delete. To check security setting, go to Security tab. Is the security level set no higher than Medium-high?

I use Firefox as my default browser, not IE. I have not used IE in decades due to its poor security reputation, and deliberately uninstall it with each OS upgrade (now Windows 7 Home Premium 64bit). This is just my personal preference, as I do not use Chrome either.

As I mentioned, there is no issue with Make 2016. If Make 2017 is using IE calls to access popups, I’ll just stick to Make 2016.

Thanks for your reply. It is appreciated.

Version 2016 uses IE calls for the same things that version 2017 does and then some more. Part of the calls in 2017 have been replaced with Chromium calls.


Your default browser is irrelevant. SketchUp does not and never has used your default browser. Until SU 2017 it used the browser library built into the operating system, namely IE on Windows and WebKit/Safari on Mac. This caused endless portability issues, both between Windows and Mac and even within Windows, where there are compatibility problems among the releases of IE. So, starting with SU 2017, SketchUp is distributed with its own embedded browser library based on Chromium, and SU’s web access is being converted to use only that library. Changing everything all at once would break too many features, so it is being done in stages.

Ok, I have it working properly now for the Warehouse pop-ups and dialogs.

Given that I completely uninstall IE, I played a hunch that Make2017 is making IE calls to a library that I may have uninstalled. So, I re-installed IE11 (still leaving Firefox as default, with no desktop shortcut, etc.) to see if a missing library was re-installed.

It looks like that was the case, as immediately after the re-install, Make2017 pop-ups displayed /operated properly.

I may delete the IE11 executable anyway (just because I will not use it), but I won’t do a complete uninstall, so that the probable library being called stays…

anyway, thanks for the info. You put me on the right track to solve it.

Modern IE is just a GUI wrapper over a web access library built into windows. that library is what SU uses. So, yes if you uninstalled the library SU won’t be able to access the web.