Install 2017 hangs asking for options for IE 11


#1

I had installed 2017 earlier but removed it when, as I closed the program, a popup from IE11 was left on my screen, ocassionally, and would not go away. I had to restart my computer. I uninstalled it. Today I clicked on the “upgrade” box that showed up in 2016. Now the same thing is happening during this upgrade process. The upgrade hangs and I have to Restart my computer. I see, in the forum, Sketchup uses IE during the process and I cannot find a solution.
E\Thanks,
Ed M.


#2

2017 does not use IE. However, upon uninstall, we do launch a questionnaire to ask why the uninstall. Is that what you’re referring to? We launch that in your default browser, not in IE by default. Is IE your default browser?


#3

No Firefox is my browser. I’ve attached the pop up that appears. I have
no idea why but it only appeared when closing 2017 when I first installed
it., but not always! I have no problem with 2016 at all.
Now when I open 2016 and click the update box this box appears over the
popup used by Sketchup installation. I cannot close either box and must
restart to do anything. I have Win 10 installed and the latest updates are
also installed.
Thanks for the quick response!
Ed M


#4

Barry,
Here is the latest screenshot of the hangup when I click the upgrade? box
when opening 2016.
Ed M


#5

SU 2016 and earlier used the default OS browser. SU17 includes Chromium.


#6

I’m having the same problem with the IE pop-up, I have to go to Windows Task Manager and force quit the IE window seeing that I do not want any of the options provided and no close button available.

I installed SU2017 fresh and not resultant from pressing the upgrade button in SU2016. I understand that chromium is the built-in browser and SU2017 doesn’t require IE any longer, but this doen’t seem to solve the problem, it’s just a nice fact to know. I use Google Chrome as my browser of choice, I’m on Windows 8.1.

Somehow SU2017 must be invoking IE as the pop-up only raises it’s head when SU2017 is run.


#7

looks like a forgotten API call to the MS IE engine in combination with the initial launch of the MS IE.

Selecting the lower option of the MS IE dialog shouldn’t harm anything and might avoid a future prompting.


#8

Unfortunately the popup will not allow anything to be entered. It is just
here and doesn’t respond!


#9

you cannot click on the radio button (= circle) before the second option?


#10

Actually SU2017 still uses IE. The native dialogs should all use the new internal browser but the WebDialog ruby class still relies on IE (or Safari for Mac).


#11

Hi Ed,

A possible workaround: Have you tried opening IE 11 on its own? That might get around the problem, since this looks like a initial setup dialog for IE that should only pop up once, after successful completion.

I’m taking a look at the install code to see if there is a resolution to the problem. Our options are limited by Window’s Installer – we request the window, but we don’t have access to the API to launch the browser.

Thanks so much for reporting the problem. I hope we can get you up and running on 2017 as soon as possible!

Bill


#12

True, @eneroth3, in order to not force all plugin developers (ourselves included) to convert their code, we left the old one in for backwards compatibility. So that’s probably the best clue - something Ruby-related.


#13

OK After making sure 2017 was properly uninstalled, I tried clicking the
"Update Now " in 2016. The IE11 popup appeared but this time I was able to
make a selection and the download and install appears to have gone OK! I
will try to replicate the original problem with the popup appearing when
closing the 2017 program. Hopefully what ever was happening has gone.
Thanks for all the help so far.
Ed M