Lord of the Toolbars display


Because everything else on my machine (and specifically within Sketchup) is displaying well, it seems like a specific LOTT display issue. Is anyone else having this issue?

What is your display scaling set to?

Hi Dan,

I’m currently at the dreaded 175% which I realize is too high. However, I set to 150% (recommended) and I even tried 100%. Neither corrected the issue. I also tried changing my resolution, but that had no cure either.

Thanks, of course, for your quick response!!!

It looks like this issue is coming from SU2024: Basically, the Load event of the dialog is never received.

This has happened in early versions of SU2024.

Do you see the same problems with other dialogs of my plugins or LibFredo6 (like CheckPluginsForUpdate)?

I guess this does not happen with SU2023. Am I correct?

FYI: SketchUp (with it’s current Qt library version) only supports displays at recommended resolution and scaling.

Also, older versions of the Chromium Embedded Framework for HTML dialogs did not include text scaling, but SU2024 updated to CEF 112 which does apply text scaling on top of display scaling.

Have you also set text scaling above 100% ?

Hi F6,

CheckPluginsForUpdate seems to show correctly and function well. This is not happening in SU2023. I’m checking my text scaling now.

Hi Dan,

I just adjusted the text scaling which instantly resolved the issue. But, I now require a magnifying glass for these old eyes!

1 Like

Dan’s suggestion for the text scaling worked. When I adjust the text scaling to 100% the display of your toolbars works correctly. Because the system/display/scale can be set at 200% (above my previous 175%) that seems to solve my eye problems. I’ll have to work with this setting for a while to see if it is good across the board.

Thanks both of you for your help!!

Hi Fredo6,

So the scaling doesn’t help with the text size, i’m stuck with switching my text size back and forth to display the LOTT correctly on sketchup. Since only LOTT has the problem (as far as I can tell) is it something that will be fixed?

Also, my LOTT menu on the windows title bar is missing the viewport maximizer and I can’t find a setting to activate it. Sorry for the thread hijacking.

image
image

Some of the features in LOTT that could be used in previous SketchUp versions could not be brought forward to SU2024 because of the Qt GUI migration.