Login Problem to Id.trimble on Mac OSX

Hi all. I want to use my SketchUp tool on Mac OSX but I cannot login any longer. After startup it asks me to login. When clicking on login it starts my browser and routes to Trimble Identity. So far so good but unfortunately there is no login form as it was previously.

Somebody had similar problems and solved it?

I frequently find that the right hand panel where the login fields should be is blank. Through experimentation I’ve found that this is due to my ad blocker. Suspending the blocker, clearing the cache, and then reloading the page fixes it.

That awkward workaround begs the question “what is the login panel doing that triggers the blocker?” Cross-site scripting? Embedded trackers? I don’t know.

Thank you @slbaumgartner for your hint.

In parallel I wrote to support and got the following answer from Erick:

  1. Close all instances of SketchUp and LayOut by right clicking on their icons in the dock, and clicking “Quit”. Failure to complete this step will prevent these steps from working
  2. Go to your desktop, you should see “Finder” and “Go” in the top left menu bar
  3. Click on “Go” Then hold the Option key and “Library” should appear in the list. Click “Library”
  4. Navigate to Application Support > SketchUp 2023
  5. Locate and delete the “login_session.dat” file
  6. Restart SketchUp and log back in

It seemed to be a combination between that written above, an old session and the ad-blocker. However, it works for me now.

1 Like

Probably the login buttons are seen as a popup window.