Login is a mess after abandonment of Google Login as of Today

I’ve been using Google login for years to get to 3d warehouse and extensions. Apparently, as of today, that’s no longer an option. Any attempt to create a new login fails. The only option is to hit Forgot Password or to hit Create Trimble password. When I try to create a Trimble password the screen then says Forgot Password, when I enter any email address I’ve ever used and hit the button, nothing happens. No error message or nothing and no email ever appears in any of the mailboxes I’ve tried.

Has anyone else experienced this as of today? Any suggestions? This is a vicious circle of going nowhere.

I’d be happy to sign in with a new Trible Sign In if I could. And if I ever can, how can I still reference all my existing extensions registered to the google login and how can I retain all the favorites and folders in the warehouse that I’ve saved over the years???

Google announce the end of the ability to sign in with Google from within applications, nearly two years ago. It took until early this year for it to really be turned off, but SketchUp was made ready for that to happen, with the SketchUp 2019.3 version.

At that point, instead of signing in from within SketchUp, you now get given a web page instead. Anyone using SketchUp 2019.3 or later can continue to sign in with Google. Anyone using 2019.2 or earlier will need to sign in with a Trimble ID.

If there is any chance you have a 2019 license, you could make sure that you are on 2019.3, and then you can continue to sign in with Google. If not, the next challenge becomes getting the Trimble ID going.

I can see that you have tried a few times. I just had a new password reset email sent to you, look for a new message, that arrived maybe 5 minutes ago. Try using the link in that email.

When choosing a password, try to keep the number of special characters down to one. There is an issue we’re looking into where if you chose two or more special characters it can make the password reset page fail.

Assuming you get further, with the new password reset and the change of a password to include only one special character, do a test sign in on sketchup.com. If the sign in works ok there, it should work from within SketchUp as well.

edit: Of course, I made a start of year error there, not quite used to it being 2021 already. Google turned off the ability to sign in with Google from inside applications, in early 2020.

1 Like

Thank you for the reset. I did finally receive and was able to sign in

Thanks for the update.

In my message I had to guess what version of SketchUp you are using. When you have a moment, could you update your forum profile, to include more details about the system and SketchUp version you are using? People read that information before answering questions, to make sure that the answer will make sense for the version that you are using.

Updated

Thank you, and yes, you do fall under the set of users who need to sign in with Trimble now.

SketchUp 2019.3 is still my “daily driver”, and I’ve been able to use “Login with Google,” but I want to migrate away from it anyway. I think there might be further confusion caused by my Google ID starting as an ISP email address, and then being forced by them to get a Gmail address later. The result may be that Trimble ended up with two different email ID’s and my license may be under one and extensions under another? IDK, but in retrospect, I’d rather just have a dedicated Trimble ID. Someone just pointed out to me that, “Now we can truly say that hindsight is 2020.”

The account works off the email address. If you sign in with Trimble, or Apple, or Google, so long as it’s the same email address you end up at the same place.