Locking components to a certain height

Hello all,
First time posting here and would love if somebody could help me out with a quick problem.

I am currently working on a project for a client in order to allow them to place components which I have created onto an image from Sketch Ups Geolocation Feature. The client does not normally work with CAD and will not have a great deal of time for me to teach him how to use the program.

Is there any way for me to set up the model so that all components will be locked at a set height? Ideally the client would be able to drag a component into the Model and have it locked so that is is just on top of the image,while still being able to move the components along the other two axis.
If it makes any difference the client will only be using the scale, move and rotate tools

Any help would be much appreciated

An image or two of what you want to do would help.
But off the top of my head, if you have a flat surface you can give them glue to components that will move about on the xy or xz etc and can’t be pulled off the surface in the 3rd dimension.

1 Like

How about using the Dynamic Components attribution to lock the height of the component.
If you were to set the component z=0, the component will position itself back to z=0 every time.

I am also looking into this as a possiblilty. Slightly off topic, but can sketch up make users rotate and scale dynamic components? I read that only Pro users can create them.

You are quite correct.

I’m trying to lock a component to the z axis by setting z =0 value in the component settings but its having no effect. If I move the item it doesn’t snap back to the 0 level. I am using the “=” sign before the value. The value box shoes a red asterix for some reason. Can anyone help with this?

Best to upload the component or the file
Otherwise, we will be guessing.

My guess: use the standard attribute Z=0

You need to add it first and only put =0 , then hit enter

edit: PosZ-> Z

Thanks for the answer. For the example it’s probably better to use a component which I saved as a wall cabinet which I want to be fixed to 137cm on the Z axis.
I have attached two screenshots, the one on the right shows what I type in the Z position value box and the one on the left is what shows after pressing the enter key. Nothing happens to the Z position of the item.
However when I type in the Z position without using the “=” sign then it positions correctly (but doesn’t remember this when I want to place the same component again in the future, which is what I am trying to achieve).

This is the component…W2-800.skp (28.8 KB)

Thnx for sharing the component. skip the units, these are set in the top, right to the components definition name (or in the details dialog, the little blue icon when entering the field)

with a little extra, a user can easily determine the height:

You should omit typing cm. If you type =137 and then hit [tab] the z value will be locked to 137cm. provided that you have set the dimensions to cm, not to inches.

(adding the units is a common mistake)

1 Like

Thanks both for your posts, its working fine now.