Locating exported 3D model in DAE format in GIS correctly

I created a 3D model after this post and exported it in KMZ and DAE.

Google Earth correctly loaded the KMZ model at the right place as shown below.
However, DAE file imported into ArcMap does not have coordinate system, thus I tested some CRSs but none of them located the model correctly.

Model_240524.kmz (71.5 KB)

Any suggestions to solve the issue?
The model was created referring to point clouds of the building, but its location was adjusted to avoid great distance from the origin issue. I wonder whether this adjustment caused the problem but the model was geolocated in SU. Any data formats are accepted.

I tried to move the imported model manually with WGS84 UTM Zone 53N. The model was located at Indonesia and moved to Japan. However the size of the model has been changed. The original length of a part was 6m but it changed to around 4m. Manual setting does not work.

I could map the model correctly in the following way:

  1. Import KMZ to CityEngine
  2. Export to DAE from CityEngine
  3. Import 3D model (DAE) into ArcMap
    I do not know why, but it worked out. Thank you.