Locating EULA error


#1

After updating from SU2015 PRO to SU2016PRO I receive the following error message:

layout cannot start due to an error locating the EULA

what can I do to remedy this issue?

Any help is appreciated


#2

LayOut looks for the EULA in the SketchUp installation directory, inside the localized resources folder. For example, on my machine it’s looking for
C:\Program Files\SketchUp\SketchUp 2016\Resources\en-US\eula.html

What language is your machine running? What language of SketchUp did you download?

-Marc


#3

Hi Marc,
the eula.html file is in the same location as you are showing.
The language is English.
Sketchup opens without a hitch, only layout gives the error message.

Jens


#4

What’s the exact version of SketchUp that you’re running? (Should look like 2016.0.xxxx or 2016.1.xxxx)

LayOut uses the system registry to locate SketchUp.exe, and then uses that location to find the eula file. The most likely explanation for this problem is that there was some sort of permissions problem during installation, so LayOut is unable to find SketchUp.

I would recommend re-downloading to make sure you have the newest version of SketchUp (2016.1.xxxx) and installing it. Don’t uninstall your current copy of SketchUp 2016 first, just go ahead and install over it. You should also run the installer as administrator (right-click, “run as administrator”) to make sure the installer can make changes to the system registry.

Thanks,
Marc


#5

It is VERY important when installing SketchUp that you select the installer-exe icon and then:
right-click > context-menu > Run as Administrator
This ensures that all permissions are set up properly during the installation.

As a ‘user’ you might have been given/set-up ‘admin-powers’, but these will almost certainly be insufficient to prevent permissions issues like this for many installations.
Simply double-clicking the exe’s icon [or selecting ‘Run’ in the context-menu] will not be sufficient to save you from this kind of problem…


#6

Thank you everybody for your quick replies. Here are detailed instructions that resolved the issue rather effortlessly .

" Please try reinstalling SketchUp and then re-adding your SketchUp license to see if that resolves the issue:

Follow these instructions below to re-install SketchUp Pro 2016:

  1. Uninstall SketchUp Pro 2016; uninstallation instructions can be found at help.sketchup.com/en/article/36209

  2. Log in to your computer with a user account that has administrative privileges.
    (Learn more at http://windows.microsoft.com/en-US/windows-vista/What-is-an-administrator-account)

  3. Please disable all anti-virus software that is running.

  4. Please visit our SketchUp Pro page at http://www.sketchup.com/download/sketchup-pro-current to download the SketchUp Pro 2016 install file.

  5. When the download completes, right-click on the install file and select “Run as administrator” and follow the on-screen instructions.

  6. After SketchUp Pro is installed, right-click on the “SketchUp 2016” icon on your Desktop and select “Run as administrator”.

  7. Click the “Add License” button in the Welcome Window and enter your license information.

  8. Re-enable your anti-virus software if it was disabled previously.

Regards,
Ty
The SketchUp Team "

Again thank you very much for your help.

Cheers,

Jens


#7

I have the Italian (IT) version installed. By mistake I made an upgrade by downloading the US/EN installer.

The installation was OK and I could use SU without problems with my current licence. Just when I opened Layout I got the some error message. Reinstalling it all didn’t work for me. Just when I realized that I had paid for the italian licence (actually I don’t care if the interface is in english or italian, since I use skechup from version 4), I downloaded the right installer and installed the IT version over the existing SU/EN version. It solved my problem.


#8

I’ve make all points from 3rdedition exactly. Several times!!! Try English and Russian version 64bit both. Only Sketchup working! Layout and Style Builder answer with the same error " cannot start due to an error locating the eula"
I understand that somthing wrong in my registry more reasonable.
But I kindly ask support guys help me.
I using the SU one month. I made first steps for SketchUp. But I could not try
other components. I’am not satisfy.


#9

Do you mean you used SketchUp 2017 Pro trial for one month but you never tried LayOut or Style Builder during that time? And now you want to try them but the trial period has ended?


#10

No, I still use SU2016 trial period but only now try use other component but there are not working.


#11

The pro trial period is only one month. After that period, the pro features are no longer available without a license. The length of the trial period clearly given.