Locating component options for dynamic components

I have read the help menu for using component options but i cannot seem to make that window appear. If i highlight a component and right click i do not see that menu option. I am using Sketchup Pro 2016 on a WIN10 machine. Is there an extension i need to add from the warehouse? thx

The component needs to be a Dynamic Component. If it is, you should see a Context menu entry for Dynamic Components and a flyout for Component Options.

Have you activated Dynamic Components from the Preferences>Extensions dialog? Dynamic Componnets are a Trimble-created extension that is automatically installed with SketchUp but you still have to activate it for use.


If I go to preferences>extensions, there is a check mark next to Dynamic Components. Have I not gone far enough down the rabbit hole?

Have you context clicked on the component to look for the menu entry as I showed in my screen shot?

I did right click the component and the only menu item regarding the component is “edit component”. I assume you mean by context click is to highlight the object and right click? I downloaded a dynamic model from 3d warehouse to test out, but no luck. I’m sure there is something I have missed. Thx for your patience.

If you look in View Toolbars, do you see an entry for Dynamic Components?

I do not see that entry.

Maybe you have an installation problem. Try installing SketchUp again and repaar the installation.

Thank you.
I will do that.

Ok, here is a recap.

· Uninstalled sketchup 2016

· Rebooted and did a fresh install from a previously downloaded installer

· Under “View”> “Toolbars” there is no menu item for “Dynamic Components”

· Under “Preferences” > “Extensions” there is a menu item called “Dynamic Components” which is checked.

· I have downloaded a dynamic component from the warehouse for testing.

· I am using ver. 16.1.1449 64-bit on Win 10 system

I didn’t mean for you to uninstall SketchUp before reinstalling it but…

Is there still no Dynamic Components item in View>Toolbars.

Sorry Dave,

I actually did try a reinstall as you suggested and hit repair. It was only after that I did the uninstall/install

There is no dynamic components as you show in your screen shot

This is strange. It shows up in the list of extensions as enabled but not in Toolbars. Just for the heck of it and because it can’t hurt. Try unchecking the box in Preferences>Extensions. Click OK and quit SketchUp. Maybe even reboot the computer. Then try enabling it again.

I’m sorry but this is one of the stranger things we’ve seen.

If you log into Extension Warehouse from inside SU, go to ‘My Extensions’…

what is the status for ‘Dynamic Components’


1 Like

Good suggestion. I should have thought of that.


This is part of an error log that pops up on SU startup.


Go home for the night. We can pick this up tomorrow. I have SU loaded on my Mac at home. I will try it there.

Ok. Not seeing your errors.

Have a great evening