Located SketchUp files but can't open them

Continuing the discussion from SketchUp Make 2016 installer deleting previous versions?:

Many thanks to all for your help I really appreciate it.
I have located the files, there were saved on an external hard drive.However, when I try to open them a notice pops up
saying “Windows can’t open this file” I would appreciate any suggestions.
Many thanks again.

What is the file extension?

I presume these are data files from an earlier version of SU.

“Windows can’t open this file,” is what Windows says when you double-click an unregistered file type, which would be true for .skb, a backup file. There is no program association for an unregistered file type, so Windows doesn’t know what to start when you double-click it. You don’t want to open the backup file anyway unless the last saved version–which gets the extension .skp–is damaged. So open the last saved .skp,

Now, the .skp file should be registered with Windows and should try to start SU when you double-click it. However, the way it works is that the version of SU most recently used to open a .skp file has the system file association, meaning that if SU 2015 was the last, that’s what will open when you double-click a .skp. If SU 2016 was most recently used to open a .skp, that’s what will open. So if you try to open a 2016 data file and SU 2015 has the association, you’ll get another “can’t open it” error, since an earlier version of the program can’t open a later-version data file.

You can use the unregistered version of SU (the one that doesn’t have the association) to open a data file, but you have to do so using the File > Open command from inside the program. From that point forward, the file association will be with that version, which will try to open when you double-click.


Hi Dave ,
The file extension is skb.

Many thanks.


The file type is skb.
Any suggestions?

Many thanks,

You must not have read my previous post. Then why ask?


Why are you trying to open .skb files? Read Gully’s post. He spent a lot of time giving good information that applies to your problem.

To put this another way…

A .skp file is a SketchUp model.
That file should open with SketchUp.exe - either on double-click or via an ‘Open’ dialog etc
If you have it set up in SketchUp Preferences it can also make a backup file in the same folder as the model.skp [the default].
After a save that backup is only one step behind the current model, so if you mess up you can use that and not lose everything [after some changes - see below…]
So you will then have two versions of each model-by-name - the original and the backup.
On a PC these backup files are suffixed as .skb
[On a MAC it uses ~.skp]
SketchUp will not open a backup file on a PC [unless you have deliberately tweaked the Registry etc or use the File>Open[filter ‘all’] method].
But if you simply rename a .skb file by changing its file-type to .skp it will then open in SketchUp in the usual ways.
Note that your Windows Explorer ‘Folder Options’ setting need to show all file-types [i.e. don’t tick the ‘Hide extensions of known file-types’].
Otherwise you’ll have two files displayed in the folder with the same name, and you will only be able to tell which is which if you view the folder’s contents in certain ways - e.g. Details, or sort by Type.

Many thanks TIG. You made something that seem so confusing so simple.


Hi folks.

From SketchUp’s File menu, using File → Open … allows the opening of backup files on PC and Mac.

Of course, the version of SU must be able to open the file, as pointed out by Gully.

Just ideas.


And of course you’ll also to need to reset the default filter in the Open dialo from *.skp, to ‘all’,
Otherwise any *.skb files are not listed…