Cannot access SKB file


#1

HI there

I recently lost all files on external hard drive, but managed to recover the majority of them. However, my original .skp files are not there, just the .skb files. I have googled this issue so much, and tried everything (the latest being renaming the file as .skp). This changed the file type to a Sketchup Model, but sketchup still does not recognise it when I try to open it! Please help! This is the only backup I have and it is quite urgent that I can access it.

Many thanks.


#2

thats odd, can you upload the skb file and we’ll give it a shot?


#3

Absolutely! How do I upload files here?


#4


#5

Thanks! Turns out I can’t upload it as the file is too big! How else could I upload it?


#6

dropbox? or whatever online cloud service you may be using.


#7

Change the extension to .skp

EDIT --> OOPS, I just saw you already did that. I’m out of ideas then.


#8

No problem!

@quantj - sorry for the delay, took forever to upload. Here is the link:


#9

unable to open it either, tried different versions. It could have corrupt from your hard drive crash, sorry. I’m out of ideas too


#10

I tried a handful of things too… no luck.
fwiw:

  • Open with or Import into SU versions back to 7 on a Mac - NOPE
  • Import into a Layout - NOPE
  • Upload to 3DWH (hoping their magic file cruncher would help) - NOPE (file too big)
  • Remove extended attributes - NOPE

Sorry. Judging by the size of the file I can guess there is a lot of work put into that file. I hope someone else can help you. I was going to try to import into AutoCAD with their .skp import extension but I could not get the AutodeskImportSkp.msi to work on a Mac. Maybe someone can try on a PC. Even if that worked, file would need a ton of clean up but it would be something.


#11

Not a problem, guys, thankyou so much for your help! A lot of my files came back corrupted when I recovered them, but I hoped that this wouldn’t be. Never mind… Leaves me with a new project to work on!

Thanks again, much appreciated.


#12

I just had a thought, may be useless…
create a new .skp with almost the same name, beside the .skb…
e.g. great_model_1.skp and great_model.skb
close SU
rename great_model_1.skp to great_model.skp

open it in SU
select File Revert and see if it imports from great_model.skb
maybe…
john