Unexpected file format with SketchUp 8


#1

Hi All,

Would really appreciate any assistance with what seems to be a corrupted file. I have been working on it all week without any issues until today when I could not open and got the “unexpected file format” error. I have been through the various topics on the forum and tried everything and anythong from the skb file to the AutoSave without any luck. File is huge so I have uploaded via dropbox. If anyone could open it, it would be a massive help.


#2

It’s been years since I’ve experienced this but I found that e-mailing the file to myself would usually fix it. I have no idea what that changed in the file but it worked. You might try that.


#3

Thanks I’ll give it a try. It’s 150MB so would emailing the link work?


#4

I doubt it. Have you tried downloading it from your dropbox link?


#5

You can install multiple SketchUp versions side-by-side, on the same computer.

Install a newer version, see if you can open the file, and if so back save it to v8 format.


#6

Thanks, but tried that. Same error. Also tried emailing it to myself. seems I have no option but to start from scratch


#7

Sometimes trying to open the problem file with a different OS works - like Mac.

One underlying problem may be the use of a corrupt image file in the SU model. If someone can open the offending file, the cause of the corruption still requires troubleshooting.

In the future, purge your SKP file often to remove unneeded clutter and - as I’m sure you will do now - make standalone backup copies.