Skb files can only be opened with 2015

bug

#1

Noticed today that the file type association for .skb files is SketchUp 2015. Tried to change it using the Windows features. Only SketchUp 2015 is brought up by default. Then I chose to find an application and selected to “SketchUp”.exe in the SketchUp 2016 folder. Change does not take. Still, I can open the .skb file through 2016 by ensuring that “all files” is set in the file open box and manually clicking on the file. So, the only problem is the association. BTW, I eventually used the Repair option in a re-installation and that did not fix the problem. Has anyone else experienced this and/or figured out how to fix the association. Perhaps, a registry fixer?


#2

There have been reports that the last opend SU version get the focus for double click opening, maybe it’s true for backup files too? (I don’t open skb directly but rename one if I need it)


#3

My SKB files have never been associated with any application, and SketchUp doesn’t create these associations by default. Someone has created it deliberately, perhaps by right-clicking on them in Explorer, and selecting the “Open With…” option. Like Cotty, I rename SKB:s if the need arises. (Similarly, Autodesk doesn’t associate its BAK files with AutoCad.)

Anssi


#4

BTW I’m using mac version.
My backup file’s extention is *~.skp, not *.skb. (original file : .skp)
So I can open backup file (
~.skp) with duble click.
Why mac version doesn’t use *.skb?


#5

The b in skb stands for backup, and this should be the backupfile for all OS. (skp + backup = skb)


#6

The naming of a backup file by inserting a ~ is a long-standing UNIX tradition. Beneath the surface, Mac OS X is a variant of UNIX.