Loading Bar Blank

Good Morning All,

I’m attempting to import an E57 Point cloud for the first time (which is taking quite a while… I’m on almost an hour of time lapsed for importing this file), and the “Loading File” dialogue box is up on my screen, but is blank. Seems like there’s a scaling issue with the box, of which I have no idea how to fix. I know I’m supposed to see a loading bar here (I’ve imported files on different computers). Anyone have any thoughts?

See screenshot. Thanks ya’ll!

Have you tried grabbing one of the corners of the dialog box with the mouse?

Dezmo - have definitely tried that, but no luck. I’ve picked at corners and edges both. Doesn’t seem to respond to resizing. I can only move the box’s location.

Hi, it could be due to a “Windows scaling” issue, and also if you are using 2 monitors with different scale factor each. It may happen that the toolbars and pop-up windows applies the scale factor from the “main monitor” while displaying onto the “secondary” one, creating similar issues.
This is difficult to identify or workaround, unless you change the scale factors of your monitors but this should not prevent the extension to work properly.

I am curious about that E57 that takes more than an hour to import. What is the size of that file ? Is it a gridded or non-gridded E57 ? If gridded, is there a lot of stations/scans in it ? and do you know approximately the number of points ?


Sorry for the late reply… I’m using a 4k monitor, and don’t have a second monitor installed. As you say, it doesn’t seem to be preventing the use of importing the cloud.

The E57 is quite a large file - 21GB. I’m not sure about being gridded or non-gridded (should I ask the scanning company? I didn’t do the scan myself), but I know there are a fair number of stations. Also, not sure about the number of points. Is there an easy way to tell, or should I ask the company that did the scan originally?

The file does eventually load, but it takes several hours. This is going to be increasingly more challenging for me, as we seem to be taking on more an more point cloud data and converting these into models in my office. I’ve also tried importing an LAS file type too, but still seems to take quite a while as the E57 does.

Also just for reference, the computer that I did the import on has an i9 13th gen Intel processor w/ 64GB of RAM.


Several Hours sounds a bit weird^^. Maybe that would be easier for us to check directly.
Do you think that would be possible to send me that file ? Privately, because of any confidentiality issues.
I will use it only locally for testing purposes.

If this is possible you can reach me at yannick_jonet@trimble.com



I’ve emailed you about the file. Hopefully you can shed some light on this with me… Thank you!


Yannick and I discovered my issue with long loading times for Point Clouds… I work in an office on a server setup. All of my files are usually loaded on the server. Trying to import a point cloud through the server is NOT recommended. Keep all of your files local, at least for the initial import. I tested this after I did the import (which for a 20GB file took only 5 minutes), and then moved everything back to the server. I was still able to relink the generated .RWP file, and then work without any issues.

Thanks Yannick!

1 Like