LO on Windows 11

Sorry RLGL…not so much of a difference. It’s a shame.

I’ve also noticed LayOut running WAY slower with Win11 than with Win10.

New Win11 PC

Old Win10 PC

The specs of your computers are very near each other so in normal SketchUp use you might theoretically not even notice any difference.

Make sure that your drivers, especially the Nvidia graphics ones, are up to date. In a new machine they are typically already months old when it reaches the customer.

Also, in the Nvidia control panel 3D application settings, make surer that SketchUp is set to use Nvidia graphics. Otherwise it might be using integrated graphics. You might also check your power saving settings, some of those may hamper performance.

https://support.sketchup.com/s/article/How-can-I-force-SketchUp-to-use-a-Specific-Graphics-Card-using-Windows-10-Settings

Unfortunately, this did not improve LAYOUT’s performance.

All my drivers and applications have the latest updates, which I performed prior to posting.

Also, I just opened the same .layout file on my old Win10 PC, and it performs better.

I’m at a loss.

1 Like