Little black dots in SketchUp Pro 2017

2017
sketchup

#1

I rencently updated my graphics card (AMD RADEON HD 6480G). Later when I opened SketchUp, I found black dots all over the display screen. I have tried multiple solutions but none seem to work.

Before you tell me to update my graphics card, it’s already up to date. And trying to disable Acceleration in Window>Preferences>OpenGL doesn’t even work because I don’t seem to have that option. I really need some help with this.

Thanks!

PS: I have a windows 7


#2

That is without doubt a graphics card issue.

The ability to turn off hardware acceleration was removed as of SketchUp 2017 because it is required by the current drawing implementation. You might try adjusting the Multisample anti-aliasing setting in that same preferences panel to see if that helps. It looks like maybe your display is very high-dpi? If so, don’t set the scaling to more than 150% in Windows. Higher settings can cause display issues in SketchUp.

I am not an expert on specific AMD graphics cards, so I can’t tell you whether that particular one is known to have issues with SketchUp or to have bad drivers, but that is something you should investigate. It sometimes happens that the latest driver release has issues not seen in earlier ones or that the release distributed with a graphics card is not the latest and bugs have been fixed.


#3

Were the dots present with an older driver? If not go back to it. The latest is not always the greatest.


#4

“multiple solutions” carries little meaning.
Have you tried reverting to the previous driver?


#5

Where did you get the driver? If you got it from your laptop manufacturer or through an automatic Windows update, it might be useful to visit the AMD website directly for the newest driver available from there.

The HD 6480G is not a discrete graphics card but a very much entry-level integrated graphics chip that is outperformed by even most of its Intel integrated rivals.

Check that your update has not switched Windows to using some other colour space than full (32-bit) colour.

You can also try turning off Fast Feedback in Window menu>Preferences >OpenGL. Note that changes you make in the dialog only become effective after you have restarted SketchUp.


#6

I got the driver directly from the AMD website. And turning of fast feedback doesn’t help. How do I switch the color space to (32-bit) color?


#7

I cheeked my scaling and it was 100%, so that wasn’t the problem. Changing the Multisample anit-aliasing didn’t work either. Any other ideas on how I could fix this?


#8

Is there a way for me to keep my driver in it’s current version with out rolling back to a previous driver? I really don’t want to go to the previous version, because it was really laggy and I had multiple issues with it (making a select amount of my programs incredibly slow and almost impossible to use them).


#9

Are things working correctly with the current graphics drivers?

As was mentioned, the problem you reported is caused by the graphics drivers. The fix is to find a graphics driver version that doesn’t cause the problem. Often that requires rolling back to a previous version. You could periodically check for new driver updates and install them to see if they work well.

Due to changes in the graphics pipeline with the release of SU2017, diabling Hardware Acceleration is not an option. This option in earlier SketchUp versions dumped rendering duties to the CPU and was useful when the user’s computer had an inadequate graphics card.

Another option you may have is to replace the AMD graphics with a suitable Nvidia GPU. Historically Nvidia graphics have proven to be the best at properly supporting OpenGL.

And as another option, since you are using the Make version, you could install SketchUp 2016 Make instead and turn off Hardware Acceleration in it’s OpenGL Preferences settings.