Sketchup 2017: display poor quality


#1

As displayed I cannot get the display good in sketchup 2017 (version 2016 was ok).
I tried changing Window -> preferences -> OpenGL settings without any change. Also Windows -> Model info -> Rendering does not brought a solution.
I tried other settings for my graphic card: no success.
What can i try further to solve this?

KR
Wannes


#2

That certainly looks like a display adapter issue. Have you tried updating the driver (SU 2017 tightened its OpenGL requirements, and some drivers that were OK for 2016 may no longer be adequate…)?


#3

Being on a laptop, by default they are set to use integrated graphics to save on power. You quickly check which you are using in SU17 > Window > Preferences > OpenGL > Graphics card details.

Card preferences are changed in the graphic card control panel itself, 3D settings. Look for the option to specify settings for individual programs, not global settings.


#4

Thanks, but my settings seems to be OK.
In sketchup 2016, I had to turn off hardware acceleration to solve this (in Window > Preferences > OpenGL), but in sketchup 2017, there is not such option.

KR


#5

Having to turn off hardware acceleration in SU 2016 is proof your graphics adapter does not provide adequate OpenGL support for sketchup . Due to changes in the display techniques used, Trimble could no longer offer the turn acceleration off option in SU 2017. Sorry…


#6

“Solving” the display issue in SU16 by disabling hardware acceleration meant SU bypassed your graphics driver for required OpenGL functionality, instead using the CPU for all software rendering.

SU17 requires hardware acceleration.

Your only recourse is to find a graphics driver for your AMD card that delivers the required OpenGL functions if you want to use SU17 without the black pattern. Go directly to the AMD site and update your driver. If the latest driver has issues, try older drivers.


#7

I do not think updating the graphics driver solves the problem, It must be either a firmware update or a new graphics card.
System requirements SU 2017: http://www.cadpoint.co.uk/sketchuppro/
Open GL 3.0 or higher.


#8

SketchUp Help Center : SketchUp Hardware and Software Requirements