Lines...Lines everywhere

I’m brand new to Sketchup but really enjoying it. Have run in to what I’m sure is (hopefully) a dumb question… Have designed something to be cut by CNC, but the shop has said that they can’t use my DXF or DWG files as there’s all these crazy lines over it. (screenshots attached) Am I missing something when I export the model? T.I.A! CAD|432x499

It’s hard to say without seeing the model itself, perhaps you could attach both the skp file and the dxf export for us to look at.

At a guess from looking at your other image it appears not to be flat. This may be due to the way you exported it or it may be the model itself. Turn on Hidden geometry in the view menu of SU to see if the edges exist in the model.
When you export you need to set the camera to Top (assuming the shape is lying down) and Parallel Projection, then export to dxf as a 3d model not a 2d and it will export true curves.

1 Like

Thanks @Box
Tower.skp (265.9 KB) Tower.dxf (1.8 MB)

So I exported it without faces, just edges, and it seems better; but now all my through- holes have moved from their spots…

Try this.
Tower.dwg (270.1 KB)

Nice one, thank you! Can you talk me through what you did? Cheers!

I did what I basically said above.
Set Camera to Parallel Projection,
Go Camera/Standard Views/Front
File/Export/3D Model
Options, only tick edges.

1 Like

Thanks for your help. I just had this back from the cut shop - are you able to point me in the right direction of what/how to fix?

“having the same problems with those files too. The issue is the use of splines and polylines, which use a number of lines to make up curves. This is usually an issue with SketchUp exports, and cant be recified without SketchUp Pro I believe. We use native software to our CNC machine, which will only accept lines and arcs, not polylines or splines.”

I don’t know how to answer that, sorry.

Try them with this one.
Tower01.dxf (147.8 KB)

Couldn’t you explode all polylines, arcs and circles (→edges) so the machine can handle these edges? The result would be the same if the segment count was high enough.

Another topic (plugin) that may help sort the arc/flipping of holes:

Thanks @Box, will send in the morning. What did you change?

Thanks @g.h.hubers; I tried that this afternoon but haven’t heard back yet :crossed_fingers::crossed_fingers::crossed_fingers:
I read somewhere that exploding arcs could lead them to be not smooth, or segmented…?

I made it fully 2d just incase it was the 3d that was causing issues.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.