Lines disappearing in Layout

I’ve been working on a document in layout and it’s suddenly started putting my label lines behind the model instead of over it. I’ve tried ‘arranging’ the model to the back and the line to the front but it doesn’t work. Is there some other setting i’ve accidentally messed with that would do it? I’ve also tried saving and closing and reopening but it’s still doing it.

Make sure the labels are on a layer higher in the list than your model viewports. If they are on a layer lower in the list, they’ll wind up behind the model viewport. Arrange only works for entities on the same layer.

aha! Thanks, I almost never use layers so I’m not quite sure how that happened but creating a new layer at the bottom for the model seems to have solved it. Thanks very much.

How did making a new layer at the bottom of the list fix your problem? You need a layer farther up in the list than your viewports are on for text and other entities that you want to show over the viewports.

I would suggest that you make layers in LayOut to separate the entities. For example I have layers in my templates in this order.

Dashed Lines and Hatches
On Every Page Text (page numbers, page titles, title block)
On Every Page Lines (page borders)

1 Like

I created a new layer at the bottom of my list called ‘base layer’ and assigned my model viewport to it, thereby putting it underneath everything else on the layout. I’ll take your advice and try similar layer options next time.

Ah! I see. Yes, that would work, too.