Dimensions hidden behind model

Hello all, not sure if I changed a setting or something changed with the latest update, but when I dimension or add text in Layout and move the dimension or text over part of the model, it gets hidden behind the model. And also, the dimension and or text shows up on all of my pages. Even if I right-click on “bring to front” the text is still hidden behind the model.

When using Layout with the same model on my laptop, all works as I expect it to.

This has to be a setting I inadvertently changed…thoughts please?


Sounds like the layer on which you are adding dimensions and labels is lower in the list than the one the SketchUp viewports are on. You should have a layer or layers for those things that is/are higher in the layer list than the one for the viewports.

Are you still using SketchUp 2020 as your profile says?

Thanks for the info DaveR, I’ll check that out as soon as I get a minute. And no, I’m using 2024 with the latest update, I looked to update my profile before posting but was in a hurry before leaving work and couldn’t find where to do that. I’ll get that taken care of too.

Click on your avatar image at the top right of the forum screen, then the person icon, Preferences, and Profile. Remember to click Save at the bottom of the page.