Line & circle not functioning, can draw them but nothing 'stays'

i select line tool and create a line, clk but not stays the line goes away, same with the circle tool
rectangle tool seems to work… strange, long time user but this i dont know. i am working in sketchup 16 pro, imac
os 10.11.5

Could you by accident be drawing on a layer that isn’t visible?

But that wouldn’t explain why rectangle tool works, I suppose

does it work in a new model?


Can you tell us a bit more about the circumstances when it first started, and what you have already tried to fix it? Eg, was it in an existing model? Does it happen in a new model? Have you restarted SU ? Rebooted your machine?

it just started, i opened and existing model to rework it and couldnt use the line tool, so i checked other tools. rectangle seems to function. i opened a new file and the line tool does not function nor the circle but the rectangle works idraw a line clk to set and the first segment does ‘register’ i have rebooted but same condition

same same new file twice still no line or circle but lots of rectangles

Faulty mouse, just possibly? I can’t think of anything else, unless SU program itself has got corrupted.

Try another mouse? Try uninstall and reinstall?

restart your mac and see if that helps…

rarely needed, but it will fix some corruptions…


interesting, i just open my sketchup on another machine and all works,
so ill go the reinstall route, that could be a good tactic tks john
and i checked the mouse it checks out, works on my other machine and other mouse (working) does the same thing

i did a full uninstall and re install now all good,
strange days… thank you for advice /tips etc
back to work

Glad for you that it is now fixed