Drawing tools stopped working


#1

I’ve created maybe 100 objects without problem. Yesterday I added 3D text to a new object, but after a few manipulations of the text I found the pencil tool would not create a line on an existing surface. Same result with the rectangle, but the circle continued to work. I closed the drawing and opened a new one. Same problem. I closed Sketchup and then reopened Sketchup and opened an old (and different) drawing. Same problem.

To be clear, the tools work for a new object in a clean, empty design, eg, draw a new line. But after the first line is created, the line tool will not draw a new line that is connected to, crossing, or touching an existing line. But it will draw a new line in open space.


#2

Can you share one of the files that this is happening to? Just upload the .SKP file, so we can take a look and help find a solution.


#3

TEXT TEST.skp (132.1 KB)
I have checked again and I can’t create a deliberate line in space in this (and other) drawings. However, if I move the cursor quickly and click randomly, I get short line segments. I looks like if the clicks are close together in time, like .3 sec or less, I get a line segment.


#4

Hmmmm… I just tried drawing some edges in your model and have no trouble.
drawing

drawing


#5

I was afraid of that. I am having the same problem in old drawings made prior to this issue showing up. I saw in other postings that the video card was a suggested problem, but this is a relatively new gaming laptop (300GB SSD, 2TB HDD) but just a simple Intel graphics chip. The OpenGL box in preferences show “fast feedback” and “0x” antialiasing sampling.

I assume that reloading Sketchup is the next step.


#6

I would start by updating the graphics drivers. Keep in mind that Intel graphics are frequently problematic in that they don’t adequately support OpenGL.


#7

I’m curious. Have you rebooted your computer since the issue occurred? Some times I just put mine to sleep.


#8

■■■■, rebooting never occurred to me. Reloading Sketchup seems to have solved the problem for now.

I am going to look into the graphics drivers issue. Lenovo keeps wanting me to install some gaming video stuff, which I decline.


#9

The last two times I had the “lagged selection tool issue” with my SU …reboot repaired it. Putting my computer to “sleep” seems to be causing some kind of issue that I don’t understand.


#10

When you installed and then reinstalled SketchUp, did you right click on the installer and choose Run as administrator? If not, close SketchUp and do it now. Choose the Repair option when it is presented.


#11

No, I installed from the downloaded .exe file by double-clicking. So now I have closed Sketchup and right clicked on the .exe file, then “run as administrator.” The only thing that happened was “OK to make changes,” the Sketchup opened without any other windows, eg, no “repair” choice.

By the way, my “devices” show two display adaptors: Intel HD graphics 630 and NVIDIA GeForce GTX 1050Ti. However, the display details under the OpenGL in “preferences” shows only the Intel device.


#12

You didn’t right click on the downloaded installer file. You have to do that and choose Run as administrator.

If you don’t do that when SketchUp is installed, it won’t get installed correctly.

Go to the Nvidia control panel (right click on the desktop) and you should be able to set the Nvidia card as the default for SketchUp.


#13

That is a Windows glitch. It is very poor at guessing the graphics requirements of applications and tends to saving electricity.
You should open the Nvidia control panel (it should be in the menu when you right-click on your desktop), go to the 3D application settings and make sure that SketchUp is set to use the NvidIa card. Automatic selection doesn’t usually work. Also check that your Nvidia drivers are up to date.


#14

Sorry, that’s what I meant. I right clicked on the Sketchup.exe installer file as administrator, not the Sketchup executable application. Still, there was no “repair” option.


#15

I personally have never run the SketchUp installer with the “Run as administrator” option, I have just double-clicked when logged in with an admin account. It might be dependent on what security software you are running, but installing without any extra gymnastics has not caused me any problems yet.


#16

The reason for using Run as administrator has been explained many times and failure to do so has proven many times to be the cause of weird problems. @TIG and @slbaumgartner have both written good guides with the reasons for using Run as administrator (and not logging in as System Administrator for installation) when installing SketchUp.

TIG wrote this and @slbaumgartner wrote this:


#17

Thanks. Got the Nvidia selected. Not sure about the “administrator” issue. I did right click “run as admin”, but it didn’t seem to have any effect. If I have further issues, I will uninstall and do that.

But this raises an admin issue. I’m always the admin. This machine is a one-person machine without a password, so I assume I’m always logged in as admin. Regardless, I’ll use the “run as admin” in the future.


#18

Read at the links I gave you. Being logged in as the administrator is not the same as using Run as administrator.


#19

I did read them. The question is, if you are automatically logged in as admin, does that screw up in any way clicking on “run as admin”? I am guessing no, but the obscurities of Windows is something I long ago avoided unless they reach out and punch me.


#20

That’s why we have “sages”