[LightUp] Exporting any 2D graphics file from SketchUp results in a blank document when model is rendered with LightUp plug in


#1

I have created a model in SketchUp and have used the LightUp plug in to render it out.

I am trying to export my model using File > Export > 2D Graphic …
When I do this with the model rendered, any file type I try to export it as comes out blank.
it seems to work fine when I export as a JPG without the render on.

I need the rendered model exported as a high resolution JPG or and EPS so that it can be used on stand graphics, which will be printed in a large format.

Has anyone had any problems like this and knows how it can be fixed?
This is a work related issue so deadlines are also a factor!
Any help would be appreciated.


#2

use the native LightUp image export instead. Its in the main LightUp menu (with the exposure settings): Capture-still. It can do very high resolutions.

edit: See page 50 of lightup pdf manual


#3

I have also tried this option LightUp > Capture >Still … but this crashes my SketchUp and does not save anything


#4

very strange. that’s the normal procedure. Have you tried posting your question on the lightup forum?
edit: I also just read on their forums LightUp v4.4e crashes sometimes. Did you try updating to the latest version?


#5

All my software is up to date I think. My LightUp is version 4.4
The LightUp forum won’t let me sign up to post the question.


#6

I have now got this to work using the native LightUp image export. I am still concerned about the quality though as I have exported to the biggest size but when I place it on the graphics it looks quite grainy full size. Is there any way I can enhance this?


#7

What resolution are you exporting to now? If I remember well(*1), you can manually increase it to very high values.
Quote from LightUps forum: LightUp can export very high resolution images. We’ve had LightUp users create 20,000 pixel wide images! LightUp’s output size is limited only by your computer memory.

*1) I can’t test it myself because I don’t use LightUp anymore.


#8

These are the options I have on the export screen. I am using the 3840 x 2160 option.


#9

I really am out of my depth here because I don’t have LightUp anymore and I also never used it on OSX.
You really should make a new account on the LightUp forum and ask your question over there. Or email your question to them. Adam (the creator of LightUp) is on this forum as well. Just follow this post tutorial by Adam click his name and press the message button


#10

I have LightUp 4.4f, on Mac. If I export with alpha selected, the TIF I get does just have whiteness where there should be texture. Without alpha I get a JPEG, and it seems to be good quality.

Can you post a model, and the JPEG that you get from it?


#11

I just noticed that in the menu Tools/LightUp/Settings, there is an option to Compress Output. If you uncheck that you’ll get a TIF instead of a JPEG, and will avoid getting JPEG artifacts.


#12

I’m unable to post any content because it’s for a paying client and not yet approved/released.

I don’t know what you mean by Alpha being selected, I have looked in the export options but don’t have this option.

I have unchecked ‘Compress Output’ and exported a tif but this still came out blank.


#13

@AdamB,Can you help?
Anssi


#14

In the screenshot you showed, scroll down a little. Below the dropdown menu you showed is options for “with depth map” and “with alpha”. Try unchecking the “with alpha” one.


#15

I have now managed to export this in high enough resolution for the job, looking great!
Thanks for all your help :slight_smile:


#16

maybe you can share your solution if someone else runs into this problem as well?


#17

I have just followed the advice given on here in terms of making sure things are checked/unchecked. Final file is a TIF which I captured through the native LightUp dialog and I exported to A2 @ 300dpi. This has been put into the document I needed it for and looks good quality at 100%


#18

Glad to hear.

As Colin commented, if you have ‘with alpha’ checked, you will get an image which is opaque where there is geometry and transparent everywhere else (eg sky). This makes it very easy to composite the Still output in Photoshop etc.


#19

One note on that Adam, the check box says “with alpha”, I was expecting to see the rendered image with an alpha channel, and not just the alpha channel itself.


#20

Colin, if your selected output file format does not support alpha, LightUp has no choice but to output a separate file. JPG does not support alpha.

If you use TIFF, its 1 image with alpha.

Adam